Great Lakes 4x4. The largest offroad forum in the Midwest banner
161 - 180 of 188 Posts

·
Registered
Joined
·
2,616 Posts
Discussion Starter · #161 ·
^^^ Could your pump go the opposite way and the filter has an anti drain back valve? Probably no it, but 1st thing that came to mind?
The pump is chain driven off the crank. The pump is pumping, oil comes out of the correct port on the side of the block. So I'll just continue to work my way up the chain, is it going into the block from the filter?

Logic says I changed the filter, it was fine and now it's not, the filter is at fault. But the fact that I changed it back and it didn't improve complicates things.

I'll figure it out though, fortunately I have 3 other project trucks to move on to when I get frustrated lol.
 

·
Registered
Joined
·
2,616 Posts
Discussion Starter · #164 ·
So, my dipstick is kind of make believe because I made my own oil pan lol, and I forgot which mark was full.

Filling the sump up and putting the old filter on, oil flows readily.

So I went through the Wix catalog to find a 1-16 thread with a bypass valve in it, the 11-16 Super Duty 6.7 filter does, the cheap one is 7.00 at Oreily's, so I put that on last night and had no problems with flow out of it.

So, I have everything on the way to replace my stupid oil pressure regulator for the turbo with a simple restricted feed, and an actual oil pressure gauge, this should be all back together by Friday or so.

And my Softopper is expected to ship Friday as well, so 2 steps back, 1 step forward I guess.
 

·
Registered
Joined
·
2,616 Posts
Discussion Starter · #166 ·
So, dinked around and dinked around with it.

Put a simple restricted feed to the turbo on it.

Welded the new 3" downpipe and smashed it with a sledge to clear the frame and slave cylinder.

Have a Ford 6.7 Powerstroke filter on it currently, has oil to top end currently. I think I may have had the lines on backwards before, I have no other explanation for why it suddenly works.

I wired a MAC valve up and plumbed it to the vacuum pump so it shuts off with the key now.

It's still super sluggish off idle, until the turbo builds boost around 1800, then it's off to the races, but until then, it's dogshit. I'll probably advance the IP a bit and see what happens there. As expensive as fuel is currently, it'll likely be getting plated and dailied while the wifes Grand Cherokee get's parked.
 

·
Registered
Joined
·
2,616 Posts
Discussion Starter · #170 ·
Drove it to work today, longest trip for it ever since I've owned it, 42 miles each way. Didn't explode, didn't die, even restarted when I went for lunch, so that's cool.

Very slow, very loud, very boring with not a lot of gauges and no radio lol. Might get adventurous and try the freeway tonight.

Stopped in and showed the local fry place what I was doing with all that oil lol.

Car Wheel Tire Land vehicle Vehicle
 

·
Registered
Joined
·
2,616 Posts
Discussion Starter · #173 ·
When I pulled into the shop Friday it seemed as if the power steering wasn't working.

Sitting down Saturday, drinking beer, and pondering my life choices, I noticed I'd thrown the belt...

Hood Automotive lighting Automotive tire Motor vehicle Road surface


I figured this was likely because it's a cobbled up serpentine setup with an LS alternator, Jeep powersteering pump, Mercedes water pump, and 6.5 diesel tensioner... So I started messing around looking to see what was misaligned, and found that I seem to have blown the front bearing out of my alternator, and lost the nut... Weird.

I'll grab another from the junkyard this week and see how it goes I guess. We're going to take it to our cottage in Gun Lake next month for 2 weeks and plan to run it around the trails there, Rouch World, and possibly head to Schied Diesel in Effingham to dyno it.

Automotive tire Motor vehicle Gear Vehicle brake Wheel
 

·
Gustafson
Joined
·
10,548 Posts
That sounds like a great time! Hopefully most of the kinks are worked out by then so you have a good trip.

Looking forward to seeing some dyno numbers!
 

·
Registered
Joined
·
2,616 Posts
Discussion Starter · #175 ·
Same, kind of amazing to me no one has strapped one to a dyno and posted the results anywhere on the internet lol.

Lot's of speculation, even one guy in a Facebook group collecting donations, but I've only ever seen one turned up OM617 on a dyno and it made 147hp/210TQ.

Which aligns with my impressions, it drives like a 90's V6, except when you take off in first, it's very slow until the rpms climb. Once it hits 1800, it's off to the races. It feels like it takes longer 800-1800 than 1800-4500 lol.

 
161 - 180 of 188 Posts
Top