Great Lakes 4x4. The largest offroad forum in the Midwest banner
1 - 6 of 6 Posts

·
Snowman
Joined
·
3,176 Posts
Discussion Starter · #1 ·
I've got a 1996 XJ and within the last week, I forgot what day exactly, my blinkers no longer function. The four way hazards work fine, but the blinkers; nada.

I have since replaced the following to no avail:

Blue Combination Relay under the steering column
Fuses for both the blinkers and the hazards
Relay in the engine compartment for the four ways and blinkers
Blinker column (the stick on the left side of the steering wheel)

None of these have done anything for me. I found THIS THREAD over on Naxja, but I don't understand his solution (on page 2).

In my fuse box by my kick panel on the drivers side, there is an empty place where there never was a flasher unit. Apparently the 96's and some 95's re-routed the flasher so it plugs into a cord that just hangs under the dash on the drivers side. It looks like a 550 flasher (pic at the bottom) but it is smaller. About 1 inch long and 3/4" diameter.

The local Dodge/Jeep dealerships parts department is at a loss, Autozone has never seen one and O'Reileys can't find anything like it either.

All the bulbs are good, and all my other electrical accessories are working as well. The trailer light plug gets nothing when I use a turn signal either, but the hazards work on the trailer.

I'm about at my wits end. Any suggestions as what to check next?

Pic of 550 flasher (only one of those two parallel prongs should be turned 90 degrees):

 

·
Fucking Zen as Shit
Joined
·
16,161 Posts
Did you check the Blinker fluid????

The turn signals and hazards use different remote resevoir's so it is possible for one to function and not the other.

While Jeep only says to use Mopar fluid Napa/murrays etc have acceptable substitutes
 

·
Snowman
Joined
·
3,176 Posts
Discussion Starter · #6 ·
I ended up filling the blinker reservoir with water so it would thin out the regular fluid to last longer.
 
1 - 6 of 6 Posts
Top