Great Lakes 4x4. The largest offroad forum in the Midwest banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,789 Posts
Discussion Starter · #1 ·
i'm installing a banks header on a 06 TJ with not even 5,000 miles on it. when i just pulled the intake manifold, i noticed that every intake port in the head has a greenish liquid tint to it, and has some brown almost glue like residual.

I've never seen that before. I know the newer (00+) 4.0L had a TSB with a coolant leak due to a bad head casting, but i don't think this is what i'm looking at. plus the actuall coolant is orange dex cool. so what could this green stuff be???
 

·
Banned
Joined
·
20,292 Posts
why are you running dexcool in your jeep???
 

·
Registered
Joined
·
1,789 Posts
Discussion Starter · #3 ·
it's not my jeep, it's a customers, and that's what's in it from the factory.

actually let me refrase that. it's a pink/orangish coolant. not sure what mopar calls their coolant nowadays. sorry.

anyways, anybody have any ideas what that green and brown glue like substance in the intake ports could be??? i've never seen that before. i was kinda wondering if for some reason the fuel is giving a green tint/reflection, but what would the brown stuff be, and why is it like glue. when i try to wipe it off with my fingers, it's really tacky and then i have a bunch of lines from the intake port to my finger just like glue.

another thing i thought about, is..............would there be anything they put in from the factory that has to "burn off" or anything??? i've never actually had a 4.0L with less than 5,000 miles open, so maybe i'm just freaking out over nothing. but just wanna make sure.
 

·
Banned
Joined
·
20,292 Posts
could the green stuff be algae?
 

·
skillicous
Joined
·
12,844 Posts
assembly lube of some sort maybe, or a coating so nothing rusts during assembly and shipping to the dealers... then sitting on the dealers lot for 6 months before it sells...
 

·
Registered
Joined
·
1,789 Posts
Discussion Starter · #6 ·
assembly lube of some sort maybe, or a coating so nothing rusts during assembly and shipping to the dealers... then sitting on the dealers lot for 6 months before it sells...
that's really what i'm hoping for. i just wanted to see if there is a problem with some of the new 4.0L's out there that i haven't encountered yet before i put this guys new headers on.
 

·
Registered
Joined
·
1,789 Posts
Discussion Starter · #8 ·
good idea topheavy. and it does have an aftermarket filter on it, but i confirmed with customer he's never oiled it. put it on straight out of the box with a pre-filter around it. the filter isn't even old enough to even be dirty yet. LOL
 
1 - 9 of 9 Posts
Top