Great Lakes 4x4. The largest offroad forum in the Midwest banner
1 - 8 of 8 Posts

·
6'-5" 209LB 16YR LEFTWING
Joined
·
15,745 Posts
Discussion Starter · #1 ·
The T-case will not engage any more on my 2002 superduty 7.3.
It just decided not to work one day when I got in the truck to use it.
No clunks or bangs, just no worky.

It is the electronic switch on the dash.

The 4x4 idiot light will come on when I first start the truck but goes out. The light will not light if I move the switch to 4 high or 4 low.

I removed the selector motor from the t-case, and it does not seem to be binding at all.

Fuses are both good.

Any Ideas?
 

·
Mmmmm Beeeer...
Joined
·
549 Posts
My boss just had similar issue on his 7.3 excursion, and just replaced the motor on the t case. He checked for signal power at motor and it was there but motor wouldn't work...
 

·
Registered
Joined
·
4,028 Posts
yes take the motor off and then apart on my 2000 7.3 the little tiny teeth in the gear box that shifts the t case were missing and it wouldnt shift the t case

i went on www.car-part.com and had one shipped from down south for 80 bucks dealer wants almost 400 for the same part
 

·
6'-5" 209LB 16YR LEFTWING
Joined
·
15,745 Posts
Discussion Starter · #5 · (Edited)
Well, I replalced the motor(which did not fix the problem) So I brought it to CTB2 who I trust. CTB2's scanner wouldn't pull the Codes, so it is currently at the local Stealership. They have had it for better then a day, and still can not diagnose.
Anybody willing to try for me? Anybody have any ideas?

I'm about ready to convert this thing to manual..................Help please.
 

·
6'-5" 209LB 16YR LEFTWING
Joined
·
15,745 Posts
Discussion Starter · #6 ·
The dealership is telling me that it is the 4x4 modulator..................Total Cost $475 for some piece of crap electronics.

Time to start looking for a manual t-case donor.
 

·
6'-5" 209LB 16YR LEFTWING
Joined
·
15,745 Posts
Discussion Starter · #8 ·
Okay the stealership has had my truck since last Thursday morning. It took them a day and a half to diagnose a bad 4x4 modulator, and so far it has taken a day and a half to install the new one. I still have not received the call that it is done yet.
I give up, if its not finished by 5 tonight, I'm sending a Tow truck over and having it towed.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top