Great Lakes 4x4. The largest offroad forum in the Midwest banner
1 - 6 of 6 Posts

·
U-Joints Fear Me
Joined
·
3,361 Posts
Discussion Starter · #1 ·
Philips SPD3100CC/17 External 16X DVD burner:

Never had a problem until last week. All the sudden after reading a DVD, once it gets through reading, the computer loses sight of the burner. It shows in My Computer still, but under a different name.
Usually is says H: DVD RAM but after reading it shows up as H: CD Drive. The computer wont talk to it either. If i hit Eject in the menu, it doesn't respond, and wont do anything until i go into Device Manager, remove the drive and reinstall it. After that i can burn the image onto a blank. Just started doing this.
Also, and its always done this, if i unplug the drive, and plug it back in the computer just beeps funny and in device manager it says "another instance of the device is still in memory" or something to that effect. I have to restart the machine to get it to work again. Kinda a pain cause its a laptop, and sometimes to like to walk away and come back but dont want to have to restart. I dont really care about that problem, but the burning is a PITA.

Anyone have any ideas. Firmware is fine, drivers are correct, and drive shows up in Device Manager as correct model and all that.
 

·
Registered
Joined
·
2,153 Posts
Did you purchase a new set of blanks since you last tried a burn? I had that happen where the burner could not handle the new densities that are out now. Had to pitch it because the mfg. was not writing firmware for it anymore. One reason I will only buy Lite-on from now on. They keep their firmware up to date and are compatible to everything.

Only other reason would be you interface has a prob.
 

·
U-Joints Fear Me
Joined
·
3,361 Posts
Discussion Starter · #3 ·
No they are the same ones. The burner is not that old, maybe 3 months. I just can't seem to find any others like it in the stores, as they've all upgraded to Philips' new burner the 18X.
 

·
Needs More Cowbell
Joined
·
661 Posts
Do you have the most recent driver available? If so.. I want to say it's an issue with the drive's hardware.
 

·
U-Joints Fear Me
Joined
·
3,361 Posts
Discussion Starter · #6 ·
Yea, well there aren't really drivers for it. It's PNP via windows. Either way, its been working fine since i bought it. Its an all-the-sudden thing.
Im thinking i might install the drive itself into a pc and run the latest firmware upgrades on it from Lite-On. I can't do that via the external case because the Lite-On updater wont recignize the drive in the case, as it shows up as a different drive hooked up to the Philips case.
Lite-on must have created that drive in 2 different ways with the same model number. Their version comes from them in either version, external or internal same model number plus or minus a "x" in the number. Mine is the same number (minus the x, saying it was designed to be internal) but in a Philips case, and has Philips name on the front.
Its really disappointing because it was a badass unit, and burned DVD's surprisingly fast.
 
1 - 6 of 6 Posts
Top