Great Lakes 4x4. The largest offroad forum in the Midwest banner

1 - 13 of 13 Posts

·
Premium Member
Joined
·
14,643 Posts
Discussion Starter #1
Tonight, when I let the clutch out in neutral, it made a weird noise as it was driving forward....also there was fluid on the ground

I dont think this is good
 

·
Covered in mud...
Joined
·
17,916 Posts
What kind of fluid? Not being goofy, just checking if its a slave cyl issue or a trans issue.
 

·
Premium Member
Joined
·
14,643 Posts
Discussion Starter #4
Slave cylinder

And it is at the dealer....trans went to shit. Cant get it out of gear, including when it is in Neutral......I drove it 50 feet with it in neutral.

Killer B thinks it is the shift fork, but Silver XJ is gonna dig into it tomorrow
 

·
Premium Member
Joined
·
4,863 Posts
Trans is probally fine, I bet its just the slave or t-out bearing itself.

Were you able to shift it into gear with the engine turned off?
 

·
I am the law.
Joined
·
29,823 Posts
Uh, if he was able to move the Jeep when the shift lever was in neutral, I don't think fixing the slave problems are going to change anything. The slave cylinder controls clutch engagement, not gear selection. He said shift fork. That's on the inside of the trans.
 

·
Premium Member
Joined
·
14,643 Posts
Discussion Starter #8
Well, it looks like the clutch is the first issue...from there they can dig in more
 

·
Recovering XJ owner
Joined
·
5,620 Posts
Dave ... we need to talk.

I'm thinking our tech and Killer B are on the same playing field.
 
1 - 13 of 13 Posts
Top