Great Lakes 4x4. The largest offroad forum in the Midwest banner
1 - 8 of 8 Posts

·
I'll Direc your TV
Joined
·
8,727 Posts
Discussion Starter · #1 ·
The 5.7L vortec in my chevy has a really loud knock when I start it up in the morning. It isn't loud in the sense that it sounds like something is going to go shooting through the hood, but loud as in high pitch, super charged lifter noise. It goes away (for the most part) after about 60-90 seconds running. The noise never fully goes away though, there is always a slight tick, tick, when running. That sounds like normal lifter/rocker arm ticks. It seems to only get extremely loud when the truck has been sitting for a while, like overnight. If it's a couple hours, the noise isn't bad at all.

As far as the whole internals of an engine, i've never done a ton of work on them. I'm not sure where to start, or how to even start diagnosing. I was going on the thought that the lifters aren't sealing right and are allowing the oil to drain out of the top end and it is taking a bit for the oil to fully lub everything once it gets running.

Is that something I should go ahead and have a shop do (replace lifters), if so, what else should I think about replacing; rocker arms, rods?
 

·
bdd
Joined
·
2,385 Posts
You may be hearing a cracked exaust manifold. A very common problem on your truck. They can make noise like a lifter until heat from the exhaust swells the crack shut.
After the truck has been sitting long enough you know it should make noise open the hood and have someone else start it while you try to pin point the noise.
 

·
I'll Direc your TV
Joined
·
8,727 Posts
Discussion Starter · #4 ·
You may be hearing a cracked exaust manifold. A very common problem on your truck. They can make noise like a lifter until heat from the exhaust swells the crack shut.
After the truck has been sitting long enough you know it should make noise open the hood and have someone else start it while you try to pin point the noise.
I have aftermarket headers, i'm sure it's not a leak there. I put new gaskets on last year, and i've checked for leaks around them already. Thanks though :beer:
 

·
I'll Direc your TV
Joined
·
8,727 Posts
Discussion Starter · #5 ·

·
I'll Direc your TV
Joined
·
8,727 Posts
Discussion Starter · #6 ·
I've done a few rounds of marvel mystery oil along with new oil and filter. The problem still persists, but it is better. The knocking/ticking at startup seems to be just as loud but it doesn't last as long, but there are times when I can still hear the tick ever after it's warmed up (that's always been like that)

So, I think my next step is I wanna try and adjust the rockers. I've watched a few videos on adjusting them on a 350 and it seems pretty simple and straightforward. Before I do that, is it really just as simple as it is in the videos? Remove valve cover, start engine and loosen a rocker till it ticks/knocks (whatever the proper term is), then tighten it till the noise goes away?

Anything I should note before I attempt to do this?
 

·
Registered
Joined
·
220 Posts
We once had a '97 Olds Cutlass (Malibu) that had lifters doing that right around 150k miles. I started running full synthetic in it for the better detergents, and would add a can of Seafoam cleaner about 100 miles before the next oil change. It never completely went away for cold starts, but it went from knocking for a mile to stopping before we reached the end of our street (1/2 a city block), and it didn't tick once warm. That took over 6 months. Sold it with 198k miles on it, and still running like a champ.

I'd be hesitant to simply madjust them, without any reason to believe they've fallen out of adjustment. Closing the tolerances to make up for a collapsed lifter doesn't sounds like a good idea.

I'd be more inclined to pull the rockers off, and spray some Chem 12 down the push rods to soak the lifters from the inside. I'd be VERY liberal with the C12, and let it soak over night, and probably spray them again and let it sit some more. Change the oil, then reattach the rockers and adjust them. I mean, if you're going to mess with adjusting them any, I'd go the extra mile and flush those buggers out as much as possible.
 

·
I'll Direc your TV
Joined
·
8,727 Posts
Discussion Starter · #8 ·
We once had a '97 Olds Cutlass (Malibu) that had lifters doing that right around 150k miles. I started running full synthetic in it for the better detergents, and would add a can of Seafoam cleaner about 100 miles before the next oil change. It never completely went away for cold starts, but it went from knocking for a mile to stopping before we reached the end of our street (1/2 a city block), and it didn't tick once warm. That took over 6 months. Sold it with 198k miles on it, and still running like a champ.

I'd be hesitant to simply madjust them, without any reason to believe they've fallen out of adjustment. Closing the tolerances to make up for a collapsed lifter doesn't sounds like a good idea.

I'd be more inclined to pull the rockers off, and spray some Chem 12 down the push rods to soak the lifters from the inside. I'd be VERY liberal with the C12, and let it soak over night, and probably spray them again and let it sit some more. Change the oil, then reattach the rockers and adjust them. I mean, if you're going to mess with adjusting them any, I'd go the extra mile and flush those buggers out as much as possible.
I've always ran full synthetic in it, the mystery is that the motor was swapped out so I really have no idea what went on with it before I had it. I was told that it had 70,000 miles but there no way to prove that or show it.

I was going to adjust them because i've read and heard that, with 350's, it's pretty common for them to go out of adjustment and a simple adjust puts them back in place. I have no idea why that happens, but I'm assuming it's part of the ticks in the engine. It runs great without any problem so I would assume I don't have a collapsed lifter, although I'm probably wrong.
 
1 - 8 of 8 Posts
Top