Great Lakes 4x4. The largest offroad forum in the Midwest banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5,329 Posts
Discussion Starter · #1 ·
okay, so i dropped the money on a fuel pump, i've been told that the codes the motor is throwing means its running to lean, and its loosing lots of power.

so, fuel filter and pump great right?

$175 later, something is still broke because the fuel pump bracket the hoses on it we're rusty as shit and i fucking broke them... i also broke 4 of the 6 bolts off that hold the fucking tank in and i broke 3 of the bolts holding the skid plate on.... just not my day today at all.... *sigh*

tonight is my birthday party though, so i won't remember today :D

just ranting a little, sorry.


in good news, i start my new job monday at 10 am at the good year place in comstock park on alpine. :D they start at like 7.50 an hour, i hope i can use the tire machine's for free and get a huge discount.... hoping. who knows.
 

·
hug life
Joined
·
10,197 Posts
Happy b-day man,
What type of vehicle?

Im right down the street from alpine, well sort of im about 2 miles east of the comstock vitalies. good to know some fellow GL4x4's in the n-hood.

btw if you get to use the tire machine for free you should hook me up and load my 33" x 12.5" claws on my 15" x 10" rims, if not cool. find out how much it cost there (discount said 80$ -lame-) and i will come up there and say whats up.

werd
-rob
 

·
Covered in mud...
Joined
·
17,915 Posts
Yeah, my pump module developed a leak on one of those hard lines where it come out, too.

You have 3 options:

1) Buy a new one, they are $$$$$

2) Find a used one.

3) Repair it. Thats what I did. I cut off the old tube on both sides, and drilled out the hole a little bigger. I ran some larger hard line in through the hole and bent it to match the factory piece. I flared it so the hose would stay in placed. The other side I used flare fittings to connect to my other hard line. I sanded it very coursely, and used JB weld on both sides to seal that piece in there.

I had tried brazing it, but it was too much heat for the bits of rubber and the wiring connections in the plate (I had a scrap spare one to try it on first.).

Its worked fine for me since I did it.

Also, replace all of those screws with hex head stainless cap screws or hex bolts.
 

·
Registered
Joined
·
5,329 Posts
Discussion Starter · #6 ·
well, i already replaced the screws with hex head screws.
another $136 will probably be fine, not sure lol. poker rob, if i can do mounting balancing for free, i'll definatally hook you up man.
yeah i was in yorkcreek last night. a few of my friends live there, i should have drank more but didn't. oh well.

the screws i pulled off the old peice i didn't even know they we're screws at first, i thought they we're bolts that we're all rounded off, i took half of them out with a 7mm socket. heh heh, the rest i twisted out with a pair of vice grips.

the line on mine is really rusty, i already tried to repair it with some JB weld putty and it didn't work so well. leaked like a siv...

thanks for the help guys, this is a dealer only item isn't it?
 

·
Registered
Joined
·
5,329 Posts
Discussion Starter · #7 ·
pokerrob, i might be able to mount and balance your tires, gimmie a few weeks of being there to get settled in.

first day on the job was cake :D
 

·
Registered
Joined
·
5,329 Posts
Discussion Starter · #9 ·
i checked with the asshole at the stealership today, he couldn't tell me if he had one in stock because i didn't have a VIN... i was like WTF do you need to know about the truck, i know pretty much everything he insisted he needed a vin. i've tried to deal with this guy before and he's an asshole.
bald guy at KOOL toyota on plainfield in Grand rapids.

he quoted me like $150ish though
 

·
Registered
Joined
·
5,329 Posts
Discussion Starter · #10 ·
think im going to try and repair it.

the guy at toyota grand rapids quoted me $255 :O
and the guy at KOOL toyota $167 and was pretty nice to me.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top