Great Lakes 4x4. The largest offroad forum in the Midwest banner
1 - 3 of 3 Posts

·
Registered
Joined
·
355 Posts
Discussion Starter · #1 ·
03 rubicon

check engine light is on i got it checked and i have a small and a large vacum leak
above 3000 rpm there is a whistling of some sort coming from something under the hood but i cant find it because my clutch fan is siezed up and i cannot hear anything but the fan to find what it is

now that i read some other posts could my gas cap be bad i do not hear vaccume or anything when i remove the cap.

anyone please help
thanks
 

·
Registered
Joined
·
355 Posts
Discussion Starter · #3 ·
You could spray some starting fluid around the area (carefully) and listen to see when the RPMs fluctuate that would help steer you to the leaks.
/|\ thanks but already tried that and could not find anything /|\




also the whistling i am hearing i dont think it would be vaccume because if anyone knows anything you get more vaccume on deceleration that you do on accelercation soo i dont think it that noise i am hearing is vaccume because i only hear it above 3000 rpm and not decelearation soo that is making me think that noise could be my belt slipping on the fan pulley since the fan is locked solid
and the vaccume leak could be bad gas cap

does that sound possible
has anyone else had this problem

i just orderd my electric fan temp sensor and will try to go get a fan today or tommorow soo ill know if that is the problem
and i just havent been to autozone to get a cap



but if that aint the problems any other ideas
:confused::confused::confused:
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top