Great Lakes 4x4. The largest offroad forum in the Midwest banner
1 - 16 of 16 Posts

·
Lurker
Joined
·
71 Posts
Discussion Starter · #1 ·
Alright truck started idling rough on Friday night, drove about 60 miles Saturday morning and then let it sit for about 4 hours. Jump back in, fire it up, it's still idling rough, drive about 20 miles and then punch the throttle. Truck boggs out for a few seconds, then finally cleans out, accelerates, and throws a check engine light.

Get the code read today, O2 sensor, buy one replace the 1 of 4 it says it bad. Same problems so i replace the other one on that side. Still the same problem. I am going to go buy the other 2 tomorrow so all are new but before spending another $135 is there anything else it could be?

Code is only for the front driver side sensor. I was thinking maybe a mass air sensor??

99 GMC K3500 w/ 454 and 170,000ish miles

Thanks
 

·
Senior Member
Joined
·
3,591 Posts
well lets just start with codes dont tell you what part is bad. all the code does is tell you what senor is picking up a reading out of spec.

dont waist your money on more senors not even the mass air.

you can easly have a o2 code come on and the o2 sencor is working in 100% order.

you cant fix or diag a car with a cheap murrays scan tool. their almost useless.
let me guess you too it to a auto zone/murrays and they told you to buy an o2 senor?
 

·
Chillin with the top off.
Joined
·
4,891 Posts
grab a can of carb cleaner and spray around the intake plenum and if the idle changes you have found your leak.
 

·
Lurker
Joined
·
71 Posts
Discussion Starter · #5 ·
Sorry code was a P0171 - Bank 1 too lean

Ya well I try not to go to Autozone but they are the only ones around here that read the codes for free. Guess i should quit being cheap and take it to a real shop.
 

·
Senior Member
Joined
·
3,591 Posts
grab a can of carb cleaner and spray around the intake plenum and if the idle changes you have found your leak.
he said it booggs when he hits the throttle, that doesn't happen with a vacuum leak
or while the problem is only on one bank
 

·
Chillin with the top off.
Joined
·
4,891 Posts
he said it booggs when he hits the throttle, that doesn't happen with a vacuum leak
Yes, but he also said it had a funny idel. I worked on alot of these 454s at the dealer and they had a problem with the upper plenum gaskets.

Also check your fuel pressure regulator, they go bad also.
 

·
Lurker
Joined
·
71 Posts
Discussion Starter · #9 ·
only exhaust leak i could find was a small leak at the connections in front of the cat. only reason i even noticed it is because water was bubbling out
 

·
Senior Member
Joined
·
3,591 Posts
Yes, but he also said it had a funny idel. I worked on alot of these 454s at the dealer and they had a problem with the upper plenum gaskets.

Also check your fuel pressure regulator, they go bad also.
possible, i don't know common problems for these but if it was an intake it would most likely see problems on both banks.

do the have separate gaskets per side?
 

·
Lurker
Joined
·
71 Posts
Discussion Starter · #11 ·
Thanks for the suggestions, i will try a little carb clean on the intake tomorrow to check that off the list. As far as the fuel pressure regulator, i don't have a pressure gauge or vacuum pump so off to the shop it goes :/

Thanks again for the suggestions.
 

·
Lurker
Joined
·
71 Posts
Discussion Starter · #13 ·
Tried spraying carb cleaner around the intake, no change in engine speed. Only looks like the truck has one fuel pressure regulator, could that cause a lean condition in only one bank? Someone told me maybe EGR valve?

Thanks again for the help
 

·
Lurker
Joined
·
71 Posts
Discussion Starter · #14 ·
Thanks for everyone's help.

Disturban was right (check the simple stuff first stupid). Plug wire was half torn off and arcing to the heat shield on the manifold on one of the cylinders.

Thanks again for the help.
 

·
Chillin with the top off.
Joined
·
4,891 Posts
cool, glad you got it fixed.
 

·
DODGE POWER!
Joined
·
1,819 Posts
when the engine light used to come on in my old truck i just unhooked the battery for a few seconds and it always went away
 
1 - 16 of 16 Posts
Top