Great Lakes 4x4. The largest offroad forum in the Midwest banner

1 - 20 of 26 Posts

·
circling the drain
Joined
·
35,864 Posts
Discussion Starter #1
I need a little help with my "bumps"

I wired up an amp that was known to work in a previous vehicle into my boat. Properly grounded, power chord blah blah.

I hooked up the cables from the stereo to the amp, speaker wires to the speakers and cablooey. Not sure if I blew the RCA outputs on the back of the stereo, of it I blew the amp, but I get nothing out of the speakers.

I don't know where to start, how to trouble shoot or what to look for....

Can someone who is car audio approved swing by over the weekend and give this knigga a hand? I need my bumps back in da boat.
 

·
Throw'in turtles........
Joined
·
2,365 Posts
Use a multi meter on the RCA's out of the stereo and see what you get. Depending on the radio output you should get anywhere from 1.5-4volts. If they are ok then bye bye amp. Toasted somehow. Usual culprit is not a good enough ground or too small of a ground wire versus the size of the amp and power wire size. Also did you have a inline fuse going to the amp from the power wire that can kill it too. If you get power from the Stereo and from the output of the amp you might have just toasted the subs. Again check it with the multimeter.
 

·
Eye candy
Joined
·
10,044 Posts
Do they still put fuses in the amps themselves? Its been so long since i touched car stereo shit....
 

·
Throw'in turtles........
Joined
·
2,365 Posts
They do put fuses in them but they are clearly visable on the outside of the amp. Usually they have 2 and vary in size pending the amp size.
 

·
newbie
Joined
·
5,818 Posts
check the fuse in the amp, they usually have lights on them also... check for a power light or a protection light.

what speakers? are they in a box? the wires could be hooked up in a way that if one comes off nothing will work.

I have seen some head units that have fuses on the RCA outputs, you might check for that. are you using a line out converter? if it is adjustable make sure it isnt turned down all the way.

double check everything, check for power on everything.

I usually hook everything up excapt for the power, after it is 100% done and everything is checked then I hook up the power.
 

·
circling the drain
Joined
·
35,864 Posts
Discussion Starter #8
both of the external fuses on the amp are good, the power light comes up, but no sound.

It's only one subwoofer, and it is hooked up.
 

·
Eye candy
Joined
·
10,044 Posts
both of the external fuses on the amp are good, the power light comes up, but no sound.

It's only one subwoofer, and it is hooked up.
Does the sub woofer work?


as in it works when connected to something else.
 

·
Registered
Joined
·
4,576 Posts
how many channels is the amp? ive blown one channel on a 4 channel amp and just swapped it. does your radio have a sub control? myne does and if you turn subs off the amps still on but no bumps. also i forgot and plugged my amp into an input once and searched like crazy tryn to figure it out to find i plugged the rcas in wrong. past that i think the above people have it nailed
 

·
circling the drain
Joined
·
35,864 Posts
Discussion Starter #11
Hmmmm I think I have pretty much tried what has been suggested other then the multimeter, I will mess with it over the weekend I guess
 

·
Pokerob is my B*tch!
Joined
·
11,515 Posts
Try bridging it. That sometimes works when you have part of your channel blown.
 

·
Poseur Extraordinaire
Joined
·
4,349 Posts
I would say your ground wire isn't actually attached properly...mine looked like everything was fine as well.....just unscrewed the ground connection, made a little more bare metal to hit and re-attached....worky good now...
 

·
Covered in mud...
Joined
·
17,916 Posts
Just to check, if you, say, plug in/out the RCA jacks while the amp is turned on, are you getting some thump/feedback out of the speakers? To verify they are amplifying whats coming in?

You have the remote line correctly wired?

Have the sensitivity/gain for the input signal level dialed up?

subwoofer hooked up to another amp (home stereo) works?
 
1 - 20 of 26 Posts
Top