Yet-to-be-Named 1994 C350 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Rig Builds and Pics
GL4x4 Live! GL4x4 Casino

Rig Builds and Pics Introduce your rig or post a buildup here.

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old August 16th, 2019, 12:10 PM   #1
302sploder
Senior Member
 
302sploder's Avatar
 
Join Date: 09-07-10
Location: Manton, Mi
Posts: 286
iTrader: (9)
Mentioned: 0 Post(s)
Default Yet-to-be-Named 1994 C350

Hey all! Long time lurker here, figure it may as well be time to start contributing. so why not, let's make a build thread or two! Tried to start one on fourdoorbronco.com, but it hasn't popped up yet.

About a month ago I purchased my C350 Centurion Bronco (this one) and have been tinkering with it since. It sports a 460/E4OD/manual shift tcase.

I've always had a fascination with these things. While working out of country, I was browsing craigslist and stumbled upon this guy. why I was on seattle craiglist is now a mystery to me. I had been wanting an OBS f250 or F350 to meet the towing wants that the little SCSB 4.9 truck isn't meeting. Got ahold of the guy the first or second day it was posted on craigslist and and after a little back and forth we started the motions of getting it bought. That proved difficult while working in Brazil, truck being in Seattle, and living in Michigan. First rodeo like that. To shorten the boring part of the story up, I had it shipped and it arrived the day after I got home from the 5 week work trip. All was good with the world.

Here it is on day one:





We figured we'd put a few tanks of gas through it and then start on the roof repairs. Here we are 6 weeks later and we've put about 2,500 miles on it. It's been across the Upper peninsula twice to the LOORS and plan to take it to the races for Crandon's 50th.

From there, we plan stab it into the garage and start on the roof repair and the few other body issues over the winter. It is a very clean truck other than the roof seam and a few layers of paint. Roof doesn't leak right now, so i'm optimistic, but preparing for the worst.



Not really ever going to be an offroader, but will hopefully be towing the jeep(s) and whatnot around before too long.

Last edited by 302sploder; August 19th, 2019 at 07:11 AM. Reason: stupid google photos
302sploder is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old August 16th, 2019, 12:17 PM   #2
302sploder
Senior Member
 
302sploder's Avatar
 
Join Date: 09-07-10
Location: Manton, Mi
Posts: 286
iTrader: (9)
Mentioned: 0 Post(s)
Default

[hopefully the pictures are working, they appear to be on my end]

Since taking it in, we've gotten some of the smaller things out of the way in between trips to the lake:


hauling 12 foot boards with the tailgate up:


hauling home 14ft steel for the new roof:



The first change was to fix the tan center seat that was stuck in the up position and had no cup holders! LAME! I happened to have a 2015 F150 center console (planned to use on another truck before impulse buying the centurion) so it got mounted up to the conveniently placed center seat mounts. That grey panel drives me nuts, so it'll turn tan when I ditch the BMW seats.

Before: (PO picture)


After:

Last edited by 302sploder; August 19th, 2019 at 07:17 AM.
302sploder is offline   Reply With Quote
Old August 16th, 2019, 12:27 PM   #3
302sploder
Senior Member
 
302sploder's Avatar
 
Join Date: 09-07-10
Location: Manton, Mi
Posts: 286
iTrader: (9)
Mentioned: 0 Post(s)
Default

The PO mentioned that the trans shifted hard. boy was he right. Often times it wouldn't even downshift into 2nd or 1st, forcing manual shifts. Often threw trans codes indicating the solenoid pack wiring to be at fault. tore into it one evening and found the harness to already be replaced.....with crimped on bullet connectors. cleaned everything up with solder and adhesive heat shrink and now it shifts consistently, albeit still harder than I'd like.

While I was under there, i cut the 3D printer loose and whipped up a switch mount to fit a Torque Converter Override switch. Down is computer controlled, Center is Forced Unlock, and up is Forced Lock. Forced lock is nice on all the two-lane highway roadtrips across the yoop. Forced Unlocked is nice around town as it keeps the confused torque converter out of the equation at lower speeds. Ultimately makes no difference unless you're really paying attention to how the torque converter acts. Still pull a whopping 10-11mpg. While I was in there, I replaced some worn switches and found some good work by centurion mounting the bullnose bronco switch in the areonose dash.









Found the oxygen sensor plug good and melted while crawling around underneath it:


Which explains the extra plug under there:

Last edited by 302sploder; August 19th, 2019 at 07:23 AM.
302sploder is offline   Reply With Quote
 
Old August 16th, 2019, 12:41 PM   #4
roll-bar Bob
Senior Member
 
roll-bar Bob's Avatar
 
Join Date: 01-20-06
Location: M CITY
Posts: 3,465
iTrader: (3)
Mentioned: 6 Post(s)
Default

FYI


Most of your photos don't work but some do


RBB
roll-bar Bob is offline   Reply With Quote
Old August 16th, 2019, 02:15 PM   #5
capone
Senior Member
 
capone's Avatar
 
Join Date: 01-16-06
Location: Clinton Township
Posts: 3,712
iTrader: (54)
Mentioned: 5 Post(s)
Default

I can only see the picture labeled day one. Good looking truck, I'm looking forward to following your thread fro updates.
capone is offline   Reply With Quote
Old August 19th, 2019, 04:38 AM   #6
sterlingfire
Senior Member
 
Join Date: 08-11-14
Location: sterling, not sterling heights...
Posts: 653
iTrader: (3)
Mentioned: 3 Post(s)
Default

No pictures at all for me
sterlingfire is offline   Reply With Quote
Old August 19th, 2019, 06:39 AM   #7
302sploder
Senior Member
 
302sploder's Avatar
 
Join Date: 09-07-10
Location: Manton, Mi
Posts: 286
iTrader: (9)
Mentioned: 0 Post(s)
Default

eff, i'll try to get that figured out. Trying to link from Google Photos with little success.

Edit: got the process down for photos. back to the show!

Last edited by 302sploder; August 19th, 2019 at 07:24 AM.
302sploder is offline   Reply With Quote
Old August 19th, 2019, 07:26 AM   #8
Lousypirate
Whoop Whoop
 
Lousypirate's Avatar
 
Join Date: 02-11-08
Location: Marne 49435
Posts: 17,193
iTrader: (46)
Mentioned: 74 Post(s)
Default

Neat ride. all photos working now.
__________________



The Kernel (46 CJ2a)

Mary Jane
Lousypirate is offline   Reply With Quote
Old August 19th, 2019, 07:42 AM   #9
302sploder
Senior Member
 
302sploder's Avatar
 
Join Date: 09-07-10
Location: Manton, Mi
Posts: 286
iTrader: (9)
Mentioned: 0 Post(s)
Default

Figured I should go through the boxes of parts the PO sent with the truck. found some solid gold!






So that do-nothing chip was plugged in immediately. lol. Gotta see if I can still cash in on that free t-shirt.
302sploder is offline   Reply With Quote
Old August 19th, 2019, 08:00 AM   #10
greygoose
Gustafson
 
greygoose's Avatar
 
Join Date: 02-18-08
Location: New Baltimore / Presque Isle
Posts: 8,554
iTrader: (1)
Mentioned: 4 Post(s)
Default

That's awesome!
greygoose is offline   Reply With Quote
Old August 19th, 2019, 08:05 AM   #11
302sploder
Senior Member
 
302sploder's Avatar
 
Join Date: 09-07-10
Location: Manton, Mi
Posts: 286
iTrader: (9)
Mentioned: 0 Post(s)
Default

The first drive across US2 at night was pretty terrible. The headlights were aimed way too low and the light output was lackluster. Couple that with rain near escanaba made for a fun few miles.

I had been wanting an excuse to HID projector swap something for quite a while, and this was as good a reason as any. Ordered up a set of ebay housings and amazon projectors and got to work. The swap was extremely simple and only took a couple evenings. The light output with decent HID bulbs and ballasts is incredible. The low beam cutoff is really nice too. All much better than just stabbing LED bulbs in and blinding everyone on the road.













pay no attention to the constant CEL. We're workin' on it.

Haven't taken any more photos of the truck with new headlights during the day. Guess i'm going to have to.
302sploder is offline   Reply With Quote
Old August 19th, 2019, 08:19 AM   #12
JohnnyJ
Low Range Drifter
 
JohnnyJ's Avatar
 
Join Date: 11-09-05
Location: Hartland, MI
Posts: 7,926
iTrader: (38)
Mentioned: 85 Post(s)
Default

Nice. I had no idea that Centurion was Michigan based. Good to see a clean example, many are rotted and beat.
JohnnyJ is offline   Reply With Quote
Old August 19th, 2019, 08:23 AM   #13
greygoose
Gustafson
 
greygoose's Avatar
 
Join Date: 02-18-08
Location: New Baltimore / Presque Isle
Posts: 8,554
iTrader: (1)
Mentioned: 4 Post(s)
Default

The lighting on those lights looks amazing! Nice upgrade!
greygoose is offline   Reply With Quote
Old August 19th, 2019, 02:50 PM   #14
fsumotorhead
N8KVB
 
fsumotorhead's Avatar
 
Join Date: 10-24-06
Location: Flat Rock, MI
Posts: 4,342
iTrader: (34)
Mentioned: 0 Post(s)
Default

I always though those things are cool!
fsumotorhead is offline   Reply With Quote
Old August 19th, 2019, 02:58 PM   #15
302sploder
Senior Member
 
302sploder's Avatar
 
Join Date: 09-07-10
Location: Manton, Mi
Posts: 286
iTrader: (9)
Mentioned: 0 Post(s)
Default

Thanks everyone! I'm a pretty big fan despite it's current issues. Couple more updates will bring this thread up to date.

This next bit is not nearly as fun. I replaced the muffler and rusty/holey/about-to-fall-apart tailpipe, which apparently the passenger exhaust manifold didn't like. Started leaking terribly at the rear port against the head right before the trip to Bark River International Raceway. That was top of the list on sunday. Read up on it and found that it's a common problem for the 460.

WEEEEEELLLLLLL, now the head has to come off. so much for that one sunday afternoon project. Grabbing a gasket set on the way home today. I am lucky enough to have my ford enthusiast grandfather who had a set of EFI 460 heads and manifolds sitting on a shelf right next to the window motors I needed for the back doors. grabbed them on a whim on Saturday. Sure glad I did!

Was reallllly tempted to order a new cam while I already had the top of the motor apart, but I am trying not to sink a whole lot of money into this drivetrain because.....reasons. That and we leave for Crandon next tuesday.

updates on that nonsense to come.
302sploder is offline   Reply With Quote
Old August 19th, 2019, 04:42 PM   #16
Zjman
Senior Member
 
Join Date: 03-28-14
Location: Corning, ohio
Posts: 286
iTrader: (1)
Mentioned: 1 Post(s)
Default

Huge bronco fan, Iíve owned several and always wanted a centurion but never could justify it. They are cool for sure. So why ya gotta pull the heads? I suspect a broken manifold bolt. Thereís a lot easier ways to get em out without pulling heads if In fact thatís the issue.



Sent from my iPhone using Tapatalk Pro
Zjman is online now   Reply With Quote
Old August 20th, 2019, 04:52 AM   #17
sterlingfire
Senior Member
 
Join Date: 08-11-14
Location: sterling, not sterling heights...
Posts: 653
iTrader: (3)
Mentioned: 3 Post(s)
Default

This thing's pretty cool!
I miss going to the races at bark river and crandon.... it's been too long
sterlingfire is offline   Reply With Quote
Old August 20th, 2019, 06:29 AM   #18
302sploder
Senior Member
 
302sploder's Avatar
 
Join Date: 09-07-10
Location: Manton, Mi
Posts: 286
iTrader: (9)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Zjman View Post
Huge bronco fan, Iíve owned several and always wanted a centurion but never could justify it. They are cool for sure. So why ya gotta pull the heads? I suspect a broken manifold bolt. Thereís a lot easier ways to get em out without pulling heads if In fact thatís the issue.
Broken stud flush in the back hole. Tried welding nuts to it: no dice. Tried Drilling: couldn't get a straight line on it, broken bits. Tried torching: messed up outer few threads before calling it. Figure it's not a huge deal to pull a head off and get a better idea.

I did realize yesterday that the truck has F3TE heads and my replacements are E7TE's. I'll try to salvage the F3, but not going to hold out much hope.


Quote:
Originally Posted by sterlingfire View Post
This thing's pretty cool!
I miss going to the races at bark river and crandon.... it's been too long
It's not too late to go again! The 50th is going to be good. Top will be coming off the bronco for the trail ride on the original 1969 Brush Run 101 course!
302sploder is offline   Reply With Quote
Old August 20th, 2019, 06:36 AM   #19
greygoose
Gustafson
 
greygoose's Avatar
 
Join Date: 02-18-08
Location: New Baltimore / Presque Isle
Posts: 8,554
iTrader: (1)
Mentioned: 4 Post(s)
Default

Quote:
Originally Posted by 302sploder View Post
Broken stud flush in the back hole. Tried welding nuts to it: no dice. Tried Drilling: couldn't get a straight line on it, broken bits. Tried torching: messed up outer few threads before calling it. Figure it's not a huge deal to pull a head off and get a better idea.

I did realize yesterday that the truck has F3TE heads and my replacements are E7TE's. I'll try to salvage the F3, but not going to hold out much hope.




It's not too late to go again! The 50th is going to be good. Top will be coming off the bronco for the trail ride on the original 1969 Brush Run 101 course!
For those of us who are not hardcore Ford aficionados, what does this mean?
greygoose is offline   Reply With Quote
Old August 20th, 2019, 07:03 AM   #20
302sploder
Senior Member
 
302sploder's Avatar
 
Join Date: 09-07-10
Location: Manton, Mi
Posts: 286
iTrader: (9)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by greygoose View Post
For those of us who are not hardcore Ford aficionados, what does this mean?
Man, I wish I knew more. from what i can tell the E heads have a slightly smaller intake valve and a slightly larger combustion chamber.

all I know is what i read on the interwebz last night. They can't put anything on the internet that isnt true, amirite?
302sploder is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Rig Builds and Pics

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:02 PM.


Powered by: vBulletin, Copyright ©2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 
Page generated in 0.57662 seconds with 87 queries