Brake Question, Piston split in half - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier All Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old June 28th, 2008, 08:16 PM   #1
Chiefwoohaw
Pokerob is my B*tch!
 
Chiefwoohaw's Avatar
 
Join Date: 11-06-05
Location: Cincinnati, OH
Posts: 11,505
iTrader: (7)
Mentioned: 0 Post(s)
Default Brake Question, Piston split in half

What would cause a piston to split in half?

About a week ago I felt my rear brake dragging on the F350. I thought it was the parking brake and played with it a while and all seemed good.

Going to work yesterday I loose all pedal and try not to kill anyone with my run away truck.

I get out of the truck and the rear passanger side is covered in brake fluid.

I pull the wheel and take off the caliper and one of the dual pistons is cracked in half and looked pretty awesome.

Swaped calipers and pads and all was good.



So . . . . what causes something like that to happen? Heat over a long time?
Chiefwoohaw is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old June 29th, 2008, 09:21 AM   #2
KILLER"B"468
Yankabilly
 
KILLER"B"468's Avatar
 
Join Date: 11-06-05
Location: Hendersonville Tn.
Posts: 7,945
iTrader: (19)
Mentioned: 1 Post(s)
Default

were they plastic or metal piston's? I have seen them broke on reman'd just from them putting them together. Who knows why they broke in your case. Are they original or reman'd calipers to start with?

I don't understand why you lost all your brakes... It should have been a low pedal but still have front brakes.
__________________
being on the eastern edge of the central time zone sucks...it gets dark WAY to early.

Quote:
Originally Posted by jeepbrattt View Post
An occasional jello or vasoline wrestling match isn't out of the question either.
KILLER"B"468 is offline   Reply With Quote
Old June 30th, 2008, 08:13 AM   #3
Chiefwoohaw
Pokerob is my B*tch!
 
Chiefwoohaw's Avatar
 
Join Date: 11-06-05
Location: Cincinnati, OH
Posts: 11,505
iTrader: (7)
Mentioned: 0 Post(s)
Default

They were Metal.

The peddle was low to let me slow down and then nothing. . . . resivor was drained and had to plead all 4 calipers. The MC is holding up though, I thought that they went bad, slealed up, woldn't work again when they were emptied. Guess I was wrong on that one.
Chiefwoohaw is offline   Reply With Quote
Old June 30th, 2008, 08:18 AM   #4
deuce228
Redneck Poser
 
deuce228's Avatar
 
Join Date: 11-07-05
Location: West Branch, MI
Posts: 7,971
iTrader: (8)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by InBBA View Post
They were Metal.

The pedal was ?low to let me slow? down and then nothing. . . . reservoir was drained and had to bleed all 4 calipers. The MC is holding up though, I thought that they went bad, sealed up, woldn't work again when they were emptied. Guess I was wrong on that one.
Drinking this morning Drew?
deuce228 is offline   Reply With Quote
Old June 30th, 2008, 09:51 AM   #5
FlatFender
Tap Tap Splat
 
FlatFender's Avatar
 
Join Date: 11-05-05
Location: Raleigh NC
Posts: 15,775
iTrader: (1)
Mentioned: 2 Post(s)
Default

Quote:
Originally Posted by InBBA View Post
They were Metal.

The peddle was low to let me slow down and then nothing. . . . resivor was drained and had to plead all 4 calipers. The MC is holding up though, I thought that they went bad, slealed up, woldn't work again when they were emptied. Guess I was wrong on that one.
Quote:
Originally Posted by deuce228 View Post
Drinking this morning Drew?
x2


wtf dude?
FlatFender is offline   Reply With Quote
Old June 30th, 2008, 10:44 AM   #6
Chiefwoohaw
Pokerob is my B*tch!
 
Chiefwoohaw's Avatar
 
Join Date: 11-06-05
Location: Cincinnati, OH
Posts: 11,505
iTrader: (7)
Mentioned: 0 Post(s)
Default

The pedal went to the flow and lost pressure at first when the fronts were operating but then nothing, not fluid and no brakes.

Yup, bad typer when multi-tasking.

but I could use a drink that is for sure!!
Chiefwoohaw is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:26 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.49982 seconds with 38 queries