Th-350 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old April 13th, 2006, 04:53 PM   #1
JDF3
Senior Member
 
JDF3's Avatar
 
Join Date: 11-07-05
Location: Marquette, MI
Posts: 249
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to JDF3
Default Th-350

It might be a stupid question but I need help. I have a full size jimmy with a TH-350 tranny that decided to shit out on me today. After a little bit of mild wheelin, I got back on the road and it would go through 1st and 2nd fine but wouldn't hit 3rd. Occasionally it'd go from 2nd to what kinda felt like neutral until I gave it a bit more gas, then it'd jerk back into 2nd momentarily. After a few more miles 2nd stopped working too. Had to crawl home going about 20 mph I checked the vaccuum line going to the modulator and it seemed to be ok. Any other ideas? Thanks alot.
JDF3 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old April 16th, 2006, 09:01 PM   #2
GMCsonoma94
1 wheel peel
 
GMCsonoma94's Avatar
 
Join Date: 11-06-05
Location: michigan
Posts: 1,577
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to GMCsonoma94
Default

did you drop the pan yet?
GMCsonoma94 is offline   Reply With Quote
Old April 19th, 2006, 06:08 PM   #3
KILLER"B"468
Yankabilly
 
KILLER"B"468's Avatar
 
Join Date: 11-06-05
Location: Hendersonville Tn.
Posts: 7,945
iTrader: (19)
Mentioned: 1 Post(s)
Default

Direct clutches most likely took a crap on you, then the forwards.
__________________
being on the eastern edge of the central time zone sucks...it gets dark WAY to early.

Quote:
Originally Posted by jeepbrattt View Post
An occasional jello or vasoline wrestling match isn't out of the question either.
KILLER"B"468 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:56 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.07659 seconds with 29 queries