2000 TJ FLuid All over ground -- HELP!!! - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old April 8th, 2006, 08:24 AM   #1
Saharaboy
Donate to Me
 
Saharaboy's Avatar
 
Join Date: 11-04-05
Location: Waterford, MI
Posts: 866
iTrader: (0)
Mentioned: 1 Post(s)
Send a message via AIM to Saharaboy
Default 2000 TJ FLuid All over ground -- HELP!!!

Ok the fluid looks like power steering fluid or maybe brake fluid, not sure, but from where it looks like it is dripping doesn't make sense to me.

HELP!!!



Saharaboy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old April 8th, 2006, 08:54 AM   #2
Yetti
Buy a Fiat! Save the UAW!
 
Yetti's Avatar
 
Join Date: 11-05-05
Location: 20 minutes south of Hell...
Posts: 14,385
iTrader: (10)
Mentioned: 2 Post(s)
Default

looks like power steering fluid
__________________
Yetti
Yetti is offline   Reply With Quote
Old April 8th, 2006, 09:07 AM   #3
Saharaboy
Donate to Me
 
Saharaboy's Avatar
 
Join Date: 11-04-05
Location: Waterford, MI
Posts: 866
iTrader: (0)
Mentioned: 1 Post(s)
Send a message via AIM to Saharaboy
Default

Ya I know, but why would it leak from there?
Saharaboy is offline   Reply With Quote
Old April 8th, 2006, 09:19 AM   #4
scorpio_vette
Senior Member
 
scorpio_vette's Avatar
 
Join Date: 12-03-05
Location: milwaukee
Posts: 1,789
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via MSN to scorpio_vette Send a message via Yahoo to scorpio_vette
Default

if it's power steering fluid, then you can find out real easy by looking at the lines. they're not that long. they only go from the pump to the box and back. if it's leaking it's pretty obvious.

is the fluid anywhere else above or next to the motor, or is it just below your pulley there???
scorpio_vette is offline   Reply With Quote
Old April 8th, 2006, 09:25 AM   #5
Saharaboy
Donate to Me
 
Saharaboy's Avatar
 
Join Date: 11-04-05
Location: Waterford, MI
Posts: 866
iTrader: (0)
Mentioned: 1 Post(s)
Send a message via AIM to Saharaboy
Default

From what I can tell it is just below my pulley there, don't see it coming from anywhere else....
Saharaboy is offline   Reply With Quote
Old April 8th, 2006, 09:36 AM   #6
KILLER"B"468
Yankabilly
 
KILLER"B"468's Avatar
 
Join Date: 11-06-05
Location: Hendersonville Tn.
Posts: 7,945
iTrader: (19)
Mentioned: 1 Post(s)
Default

Hey john look on the back of the power steering pump see if it is wet. Also check the lines up there. Look at where the power steering hoses go by the steering shaft. if I remember correctly they looked worn as well as polishing a spot on the steering shaft. It may have worn a hole in the power steering hose.
__________________
being on the eastern edge of the central time zone sucks...it gets dark WAY to early.

Quote:
Originally Posted by jeepbrattt View Post
An occasional jello or vasoline wrestling match isn't out of the question either.
KILLER"B"468 is offline   Reply With Quote
Old April 8th, 2006, 09:55 AM   #7
Saharaboy
Donate to Me
 
Saharaboy's Avatar
 
Join Date: 11-04-05
Location: Waterford, MI
Posts: 866
iTrader: (0)
Mentioned: 1 Post(s)
Send a message via AIM to Saharaboy
Default

Bill,

It is definatly not the hose, and for the most part the pump looks pretty dry, just dirty...not really sure.

I am assuming you are home, think I could bring it over for you to look at?

I tried calling but you didn't answer.
Saharaboy is offline   Reply With Quote
Old April 8th, 2006, 10:32 AM   #8
Saharaboy
Donate to Me
 
Saharaboy's Avatar
 
Join Date: 11-04-05
Location: Waterford, MI
Posts: 866
iTrader: (0)
Mentioned: 1 Post(s)
Send a message via AIM to Saharaboy
Default

anyone else have a guess?
Saharaboy is offline   Reply With Quote
Old April 8th, 2006, 10:44 AM   #9
5.9zj
Senior Member
 
5.9zj's Avatar
 
Join Date: 11-06-05
Location: Hartland
Posts: 285
iTrader: (2)
Mentioned: 0 Post(s)
Default

could it be a little bit of coolant dripping from your water pump?
5.9zj is offline   Reply With Quote
Old April 8th, 2006, 10:59 AM   #10
Saharaboy
Donate to Me
 
Saharaboy's Avatar
 
Join Date: 11-04-05
Location: Waterford, MI
Posts: 866
iTrader: (0)
Mentioned: 1 Post(s)
Send a message via AIM to Saharaboy
Default

It is definatly coolant....I filled my resovior last weekend cause it was low and now its down to the ADD part again....

FUCK!!!

ANYONE WANT TO BUY A TJ???
Saharaboy is offline   Reply With Quote
Old April 8th, 2006, 01:30 PM   #11
Tonka
YJ build in progress
 
Tonka's Avatar
 
Join Date: 11-05-05
Location: Lapeer Township, Mi.
Posts: 2,063
iTrader: (9)
Mentioned: 1 Post(s)
Send a message via AIM to Tonka Send a message via Yahoo to Tonka
Default

I'm willing to bet you just need a water pump. there is a weep hole that will leak a little fluid when it goes bad. They are fairly cheap.
Tonka is offline   Reply With Quote
Old April 8th, 2006, 01:39 PM   #12
brewmenn
Grumpy old man.
 
brewmenn's Avatar
 
Join Date: 11-05-05
Location: Inkster, MI
Posts: 10,508
iTrader: (9)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by Tonka
I'm willing to bet you just need a water pump. there is a weep hole that will leak a little fluid when it goes bad. They are fairly cheap.
yep, what i was thinking. I've got through a few.
brewmenn is offline   Reply With Quote
Old April 8th, 2006, 01:41 PM   #13
Sonicjay
Senior Member
 
Join Date: 11-05-05
Location: around
Posts: 2,566
iTrader: (16)
Mentioned: 2 Post(s)
Default

I think I may have a water pump for you. I replaced mine once trying to solve another problem. I'm pretty sure it's still good.
Sonicjay is offline   Reply With Quote
Old April 8th, 2006, 03:08 PM   #14
Saharaboy
Donate to Me
 
Saharaboy's Avatar
 
Join Date: 11-04-05
Location: Waterford, MI
Posts: 866
iTrader: (0)
Mentioned: 1 Post(s)
Send a message via AIM to Saharaboy
Default

It is the water pump, and I got a brand new one at murrays for $33, also picked up a new belt since its coming off anyways.

Thanks everyone for your help!!!

Saharaboy is offline   Reply With Quote
Old April 8th, 2006, 05:05 PM   #15
Gunsworth
Senior Member
 
Gunsworth's Avatar
 
Join Date: 11-07-05
Location: Birmingham
Posts: 2,548
iTrader: (12)
Mentioned: 2 Post(s)
Send a message via AIM to Gunsworth
Default

haha, was gonna say to check all yer fluids and see which one is low, glad to see ya figured it out....water pump is not a bad job either
Gunsworth is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:18 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.19770 seconds with 65 queries