Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Quads, Bikes, and Sleds
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old February 29th, 2008, 08:51 PM   #1
Flexin' XJ
Senior Member
 
Flexin' XJ's Avatar
 
Join Date: 02-04-07
Location: Holt, MI
Posts: 4,456
iTrader: (19)
My new toy



Flexin' XJ is offline   Reply With Quote
Old March 1st, 2008, 08:48 AM   #2
TOOLTIME
Senior Member
 
Join Date: 02-03-08
Location: WESTLAND MI
Posts: 112
iTrader: (2)
NICE...YOU GONNA SLAP AN ORV STICKER ON THAT THING OR JUST USE IT AROUND THE HOUSE?? EVER WANT TO RIDE, LOOK ME UP ON WWW.ATVOFFROAD.NET SAME USER NAME THERE TOO. WERE ALWAYS RIDING SOMEWHERE....
TIM
TOOLTIME is offline   Reply With Quote
Old March 1st, 2008, 05:22 PM   #3
smasheromalley
Senior Member
 
smasheromalley's Avatar
 
Join Date: 11-06-05
Location: Michigan
Posts: 3,036
iTrader: (15)
nice machine, Im not exactly good on years, but that looks 95-ish? My bro in law has one and works the shit out of it year round, the only thing he's had to upgrade is the Ujoint drive axles to the CVtype IIRC
smasheromalley is offline   Reply With Quote
Old March 1st, 2008, 07:36 PM   #4
Motor Slut
I put the Ick in Dick.
 
Motor Slut's Avatar
 
Join Date: 11-10-05
Location: 49963
Posts: 2,411
iTrader: (0)
Quote:
Originally Posted by smasheromalley View Post
nice machine, Im not exactly good on years, but that looks 95-ish? My bro in law has one and works the shit out of it year round, the only thing he's had to upgrade is the Ujoint drive axles to the CVtype IIRC

Closer to '98-99

Those things are nearly bulletproof.
Motor Slut is offline   Reply With Quote
Old March 2nd, 2008, 07:55 AM   #5
Flexin' XJ
Senior Member
 
Flexin' XJ's Avatar
 
Join Date: 02-04-07
Location: Holt, MI
Posts: 4,456
iTrader: (19)
97 actually. Has some small issues that I found only after purchasing it and using it to plow.

After using it for a while, steam starts coming out of the front panel area. Smells like coolant but there is nothing leaking. And the radiator is full.

The fan rattles, no big deal.

Rear brake does not work (the guy told me about this. There is one on ebay I might purchase)

Stalls once in a while while using it.

The thing is a tank though. Rode it out at my parents house yesterday and went through the foot of snow like nothing. Over at my uncles property there was like 18" and it wouldn't do very well in that stuff.
Flexin' XJ is offline   Reply With Quote
Old March 3rd, 2008, 08:29 PM   #6
Motor Slut
I put the Ick in Dick.
 
Motor Slut's Avatar
 
Join Date: 11-10-05
Location: 49963
Posts: 2,411
iTrader: (0)
Steam is excess coolant stuck in the fins burning off. Should stop eventually.

Those fans are notorious for going bad and rattling around.

The rear brake probably just need to be bled. It takes a lot of work to bleed the system but that's the most common issue. A mity vac works wonders.

The stalling could be a faulty throttle sensor or loose throttle cable.
Motor Slut is offline   Reply With Quote
Old March 3rd, 2008, 08:34 PM   #7
Mclovin
"The Situation"
 
Mclovin's Avatar
 
Join Date: 11-07-05
Location: Dearborn Heights, Mi
Posts: 14,390
iTrader: (15)
Send a message via AIM to Mclovin Send a message via Yahoo to Mclovin
Nice.. i've been thinkin about going to a Utility quad.. i do more trail riding than dunes but i know when i go to the dunes ill be kicking myself.. hmm maybe i need both
Mclovin is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Quads, Bikes, and Sleds
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:13 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.09812 seconds with 26 queries