95 Tacoma Needs some love - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Toyota Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old March 2nd, 2008, 12:36 AM   #1
martsparts
Senior Member
 
Join Date: 02-22-08
Location: Ypsilanti,Mi
Posts: 100
iTrader: (7)
Mentioned: 0 Post(s)
Default 95 Tacoma Needs some love

Just picked up a 95 Tacoma reg cab 4X4 2.7 5spd. Has not run in a year. Fuel tank was rusted at the seam and leaking the guy said. One day it just quit on him and he parked it. He gave me a new(used )tank and a new filter. Did the basic, 150# compression, spark. Have the tank down but cant hear any pump running? And where in the hell is the fuel filter located. If I have to put a pump on it I will while the tank is down for the swap. Any input would be greatly appreciated.
martsparts is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old March 2nd, 2008, 10:24 AM   #2
aimmotorsports
Senior Member
 
aimmotorsports's Avatar
 
Join Date: 05-13-07
Location: howell, mi
Posts: 918
iTrader: (14)
Mentioned: 0 Post(s)
Default

have you checked to see if the pump is getting power yet?
aimmotorsports is offline   Reply With Quote
Old March 2nd, 2008, 08:04 PM   #3
martsparts
Senior Member
 
Join Date: 02-22-08
Location: Ypsilanti,Mi
Posts: 100
iTrader: (7)
Mentioned: 0 Post(s)
Default

Powered it up this am when I put the new tank in. Replace the hidden under the intake fuel filter, still had no fuel. EFI relay was bad. Runs like a watch. 190K mi and still has 150# comperssion. Thanks for the help
martsparts is offline   Reply With Quote
Old March 4th, 2008, 07:36 PM   #4
Rattler
Home Sweet Homicide
 
Rattler's Avatar
 
Join Date: 04-17-06
Location: Bei City
Posts: 3,658
iTrader: (1)
Mentioned: 0 Post(s)
Default

Welcome to Toyland. When you gonna take it wheelin'?
Rattler is online now   Reply With Quote
Old March 22nd, 2008, 10:00 PM   #5
martsparts
Senior Member
 
Join Date: 02-22-08
Location: Ypsilanti,Mi
Posts: 100
iTrader: (7)
Mentioned: 0 Post(s)
Default

Hope to get it dirty soon. Have to fix a broken rear spring then its ready.
martsparts is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Toyota Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:00 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.11485 seconds with 35 queries