It's been a while; new flatbed pics! - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > General 4x4 Stuff > The Pub
GL4x4 Live! GL4x4 Casino

The Pub A friendly forum where everybody is nice, and will answer any questions you have about life.

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old February 29th, 2008, 09:24 PM   #1
Sonicjay
Senior Member
 
Join Date: 11-05-05
Location: around
Posts: 2,566
iTrader: (16)
Mentioned: 2 Post(s)
Default It's been a while; new flatbed pics!

Stupid wheels..











When the wheel came off, I was in the slow lane on 696 at least; as soon as I felt it let go I started slowing down and pulling onto the shoulder; then the Jeep dropped into mad-flex position and made a sweet shower of sparks. As the wheel started to pass me on the right, with the damn axle shaft still on it, I tried to "herd" it by trapping it between me and the wall, but it got away, crossed all 4 lanes of traffic (as other cards rapidly stopped), bounced off the center wall, then around the curve of the turn I was heading into, back across all four lanes and out of site (which was across the bottom of the entrance ramp that was being heavily used in rush hour), then right up the snowy embankment about 3/4 of the way. I kick ass at Jeeps, LOL
Sonicjay is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old February 29th, 2008, 09:29 PM   #2
xjmichigan
Senior Member
 
xjmichigan's Avatar
 
Join Date: 11-05-05
Location: Plymouth
Posts: 4,328
iTrader: (16)
Mentioned: 1 Post(s)
Default

was your front disco'd for that flex pic?



glad it was not any worse
xjmichigan is offline   Reply With Quote
Old February 29th, 2008, 09:29 PM   #3
ddeadserious
Senior Member
 
ddeadserious's Avatar
 
Join Date: 08-20-06
Location: Plymouth, MI
Posts: 5,078
iTrader: (44)
Mentioned: 0 Post(s)
Send a message via AIM to ddeadserious
Default

Wow.. Glad you're alright.
ddeadserious is online now   Reply With Quote
Old February 29th, 2008, 09:30 PM   #4
Dave Kerwin
web wheeling, hard.
 
Dave Kerwin's Avatar
 
Join Date: 11-18-05
Location: SE MI
Posts: 6,689
iTrader: (9)
Mentioned: 3 Post(s)
Default

oh man, that sucks!

kinda funny though
Dave Kerwin is online now   Reply With Quote
Old February 29th, 2008, 09:30 PM   #5
zanderman90
MTU here I come.
 
zanderman90's Avatar
 
Join Date: 10-18-06
Location: Haslett,Mi
Posts: 282
iTrader: (0)
Mentioned: 0 Post(s)
Default

shitillbuffout
zanderman90 is offline   Reply With Quote
Old February 29th, 2008, 09:31 PM   #6
jthomp
Senior Member
 
jthomp's Avatar
 
Join Date: 06-01-06
Location: Linden MI
Posts: 980
iTrader: (11)
Mentioned: 0 Post(s)
Default

That sounds like a...
jthomp is offline   Reply With Quote
Old February 29th, 2008, 09:32 PM   #7
Dave Kerwin
web wheeling, hard.
 
Dave Kerwin's Avatar
 
Join Date: 11-18-05
Location: SE MI
Posts: 6,689
iTrader: (9)
Mentioned: 3 Post(s)
Default

wait a minute, how did you break an axle shaft on the highway? were you wheeling snow banks at the mall before hopping on the highway?
Dave Kerwin is online now   Reply With Quote
Old February 29th, 2008, 09:35 PM   #8
One Arm Steve
I was born in the desert
 
One Arm Steve's Avatar
 
Join Date: 11-20-05
Location: Harrison
Posts: 1,719
iTrader: (4)
Mentioned: 0 Post(s)
Default

Glad to see no one got hurt (besides your pride). How the hell did you loose the axle??
One Arm Steve is offline   Reply With Quote
Old February 29th, 2008, 09:36 PM   #9
blownexploder94
Todd
 
blownexploder94's Avatar
 
Join Date: 11-22-07
Location: South Lyon
Posts: 1,074
iTrader: (6)
Mentioned: 0 Post(s)
Default

from the pic doesn;t look like the axle shaft snaped maybe something in the carrier let go
blownexploder94 is offline   Reply With Quote
Old February 29th, 2008, 09:38 PM   #10
Romey
Senior Member
 
Romey's Avatar
 
Join Date: 11-05-05
Location: Waterford MI
Posts: 1,958
iTrader: (1)
Mentioned: 0 Post(s)
Default

I think its because you have three stickers on your bumper on that side. If you had the same amount on both sides I am sure this would not have happened.

Glad you are ok.
Romey is offline   Reply With Quote
Old February 29th, 2008, 09:43 PM   #11
jeepfreak81
81 inches of fun
 
jeepfreak81's Avatar
 
Join Date: 11-10-05
Location: Lennon, Mi
Posts: 12,213
iTrader: (21)
Mentioned: 0 Post(s)
Send a message via AIM to jeepfreak81 Send a message via MSN to jeepfreak81 Send a message via Yahoo to jeepfreak81
Default

Broken C-Clip?
jeepfreak81 is offline   Reply With Quote
Old February 29th, 2008, 09:51 PM   #12
Sonicjay
Senior Member
 
Join Date: 11-05-05
Location: around
Posts: 2,566
iTrader: (16)
Mentioned: 2 Post(s)
Default

Quote:
Originally Posted by jeepfreak81 View Post
Broken C-Clip?


Yeah, the shaft didn't break, just came out (well, chewed up the splines when it hit the concrete wall at 70mph..)
Sonicjay is offline   Reply With Quote
Old February 29th, 2008, 09:53 PM   #13
Sonicjay
Senior Member
 
Join Date: 11-05-05
Location: around
Posts: 2,566
iTrader: (16)
Mentioned: 2 Post(s)
Default

Quote:
Originally Posted by xjmichigan View Post
was your front disco'd for that flex pic?



glad it was not any worse
Anti-Rock swaybar; kinda nice, as I still had three wheels in contact and was able to steer pretty good considering.
Sonicjay is offline   Reply With Quote
Old February 29th, 2008, 09:55 PM   #14
Sonicjay
Senior Member
 
Join Date: 11-05-05
Location: around
Posts: 2,566
iTrader: (16)
Mentioned: 2 Post(s)
Default

Quote:
Originally Posted by One Arm Steve View Post
Glad to see no one got hurt (besides your pride). How the hell did you loose the axle??
What is this pride you speak of?

Yeah, when that wheel started heading for the wall, I was scared it was gonna jump the wall into on-coming traffic. That would've been really bad. It worked out really well considering; no one was hurt, thank God!
Sonicjay is offline   Reply With Quote
Old February 29th, 2008, 10:49 PM   #15
ovrlnd
HURL SCOUTS
 
ovrlnd's Avatar
 
Join Date: 03-23-07
Location: Westland, Michigan
Posts: 10,003
iTrader: (14)
Mentioned: 0 Post(s)
Send a message via AIM to ovrlnd
Default

glad you are alright and no other motorists were injured.
what rearend? turdie5? what size tire are you running?
ovrlnd is offline   Reply With Quote
Old February 29th, 2008, 11:14 PM   #16
Sonicjay
Senior Member
 
Join Date: 11-05-05
Location: around
Posts: 2,566
iTrader: (16)
Mentioned: 2 Post(s)
Default

Quote:
Originally Posted by ovrlnd View Post
glad you are alright and no other motorists were injured.
what rearend? turdie5? what size tire are you running?
Nope, D44 and 35's
Sonicjay is offline   Reply With Quote
Old February 29th, 2008, 11:20 PM   #17
Rockstar
sɐƃǝʌ sɐן
 
Rockstar's Avatar
 
Join Date: 07-25-07
Location: Taylor,Mi
Posts: 8,504
iTrader: (11)
Mentioned: 3 Post(s)
Default

Jay that looks great
Rockstar is offline   Reply With Quote
Old March 1st, 2008, 12:07 AM   #18
mpwal099
Stick it up your ass
 
mpwal099's Avatar
 
Join Date: 03-05-06
Location: Plymouth
Posts: 3,070
iTrader: (11)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Sonicjay View Post
Front page quality right there.

Seriously, Happy all turned out ok.
__________________
Quote:
Originally Posted by Stan View Post
I feel, for the most part, we have a whole generation of worthless, lazy, pieces of shit.
Quote:
Originally Posted by Fatty Matty View Post
A good chunk of the younger generation is really fucked up. Not all of them, but a good amount.
mpwal099 is offline   Reply With Quote
Old March 1st, 2008, 12:13 AM   #19
Loomis
Senior Member
 
Loomis's Avatar
 
Join Date: 11-06-05
Location: Warren
Posts: 642
iTrader: (2)
Mentioned: 0 Post(s)
Default

Damn, Jay that sucks! Just your luck buddy!!!
Loomis is offline   Reply With Quote
Old March 1st, 2008, 06:11 AM   #20
Coynster
ecoyne
 
Join Date: 11-06-05
Location: Metro Detroit, MI
Posts: 422
iTrader: (0)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Sonicjay View Post
Nope, D44 and 35's
What kind of axle is that D44? I'm not familiar with D44's using C-clips... does yours not use the retaining plate? That is a crazy situation!
Coynster is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > General 4x4 Stuff > The Pub

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:59 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.24977 seconds with 80 queries