Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old February 27th, 2008, 12:25 PM   #1
94KOTA
Buy American!
 
94KOTA's Avatar
 
Join Date: 06-06-07
Location: Traverse City Michigan
Posts: 218
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via AIM to 94KOTA
Default Explorer Steering???

I have a 94 Explorer 4x4, when I turn say from a dead stop out of somewhere 90 degrees left or right on to a road say at an intersection. after completing the turn and go to turn the wheel back straight. The car wants to stay turning and the wheel is hard to turn back to straight, steering is very stiff. I checked the ps fluid and its full, my pump is not whinning and and i dont see any leakage.. it doesnt happen all the time but more recently. And the toe in and out of the tires doesnt look like it could be a problem...it has 31s but its never been hard to steer til now...Any advice?
Thanks Nick
94KOTA is offline   Reply With Quote
Old February 27th, 2008, 12:35 PM   #2
CheapThrillB2
FAWK YEAH!!
 
CheapThrillB2's Avatar
 
Join Date: 09-06-06
Location: Middleville, MI
Posts: 30,798
iTrader: (61)
Mentioned: 3 Post(s)
Default

soundsb like either or a
stiff ball joint
stiff ujoint
bad power steering pump
CheapThrillB2 is offline   Reply With Quote
Old February 27th, 2008, 12:51 PM   #3
94KOTA
Buy American!
 
94KOTA's Avatar
 
Join Date: 06-06-07
Location: Traverse City Michigan
Posts: 218
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via AIM to 94KOTA
Default

how do i check if its a ball joint or u joint?
94KOTA is offline   Reply With Quote
Old February 27th, 2008, 01:09 PM   #4
CheapThrillB2
FAWK YEAH!!
 
CheapThrillB2's Avatar
 
Join Date: 09-06-06
Location: Middleville, MI
Posts: 30,798
iTrader: (61)
Mentioned: 3 Post(s)
Default

jack it up, take the tie rod off a spindle, turn left to right and see if difficult. Then turn the axle shaft a little bit a recheck. Do this on both sides
CheapThrillB2 is offline   Reply With Quote
Old February 27th, 2008, 01:17 PM   #5
88mudder
In the band!
 
Join Date: 03-30-06
Location: waterford michigan
Posts: 3,678
iTrader: (29)
Mentioned: 0 Post(s)
Send a message via AIM to 88mudder Send a message via Skype™ to 88mudder
Default

Quote:
Originally Posted by CheapThrillB2 View Post
jack it up, take the tie rod off a spindle, turn left to right and see if difficult. Then turn the axle shaft a little bit a recheck. Do this on both sides
x2

i just pulled my shafts out and both joints were completly froze up. Thats solves that noise it was making..
88mudder is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:49 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.09531 seconds with 22 queries