Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old December 29th, 2007, 03:21 PM   #1
72cj304
Senior Member
 
72cj304's Avatar
 
Join Date: 02-09-06
Location: dexter mi
Posts: 393
iTrader: (7)
Mentioned: 0 Post(s)
Default 1978 auto shift problem

it is a 1978 dodge 1/2 ton 2 wheel drive 318 with 727 trans did a motor swap to a 82 318 4bbl replaced rad and put trans cooler on problem is when you put in rev it is fine when you put it in drive it slips untill you hit the gas I was told that the kick down linkage may be the problem the trans was fine before the swap it has a edelbrock carb and I put the throttle lever kit on still no change I checked the fluid with the engine warm and running it is at the full line any infro would be great thanks
72cj304 is offline   Reply With Quote
Old December 29th, 2007, 04:06 PM   #2
Kodiak450r
Keep on truckin
 
Kodiak450r's Avatar
 
Join Date: 11-14-07
Location: Waterford, MI
Posts: 5,910
iTrader: (19)
Mentioned: 0 Post(s)
Default

yea sounds like you might have to adjust the kickdown linkage.
Kodiak450r is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:59 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.05215 seconds with 14 queries