fuel pump issues, please HELP!!!! - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Suzuki Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old February 7th, 2008, 02:18 PM   #1
fordbuff8404
SWAMPER JR this spring!
 
fordbuff8404's Avatar
 
Join Date: 12-23-06
Location: Warren
Posts: 51
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to fordbuff8404 Send a message via Yahoo to fordbuff8404
Default fuel pump issues, please HELP!!!!

so i have a 94 tracker, the thing cut out on me and wont start. no fuel comming in so i immediatley went to the relay. its good. so then i went to the pump. got the new pump plugged in and...nothing. i tried to jump the relay and that didnt work. made sure the connections were good. can a pcm cause thins friggin annoying problem? can i just wire up a pump switch and forget about the damn relays? please help if you have had similar problems.
fordbuff8404 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old February 7th, 2008, 02:39 PM   #2
Kodiak450r
Keep on truckin
 
Kodiak450r's Avatar
 
Join Date: 11-14-07
Location: Waterford, MI
Posts: 5,911
iTrader: (19)
Mentioned: 1 Post(s)
Default

go back to the pump and see if your getting power to the pump during the key on prime cycle. it will only do that once untill you try cranking it. if your getting power to the pump then the pumps dead. if your not getting power then you need to trace the wires back to the front and look for any broken wires. if they all check out then let me know i can look up a wiring diagram for you.
Kodiak450r is offline   Reply With Quote
Old February 7th, 2008, 03:03 PM   #3
JeepInABox
Jeep yard art collector.
 
JeepInABox's Avatar
 
Join Date: 10-25-07
Location: Fenton
Posts: 2,345
iTrader: (8)
Mentioned: 0 Post(s)
Default

Had a problem with my Neon last week.
My fuel line froze, I could hear the pump but nothing was making it to the fuel rail.
2 bottles of dry gas and a 50 degree day helped melt it.
JeepInABox is offline   Reply With Quote
Old February 7th, 2008, 08:25 PM   #4
bow-tie-boy
Mean Little Fucker!!
 
bow-tie-boy's Avatar
 
Join Date: 05-01-07
Location: Ft. Hood, Texas
Posts: 72
iTrader: (0)
Mentioned: 0 Post(s)
Default

check your ground too. If all else fails, then yes you can hook it to a switch.
bow-tie-boy is offline   Reply With Quote
Old February 9th, 2008, 12:16 AM   #5
fordbuff8404
SWAMPER JR this spring!
 
fordbuff8404's Avatar
 
Join Date: 12-23-06
Location: Warren
Posts: 51
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to fordbuff8404 Send a message via Yahoo to fordbuff8404
Default

well i appreciate the tips, some thing was wrong in the fuel pump relay circuit, i jumped it with a key on power source and now the pump works fine. and i also learned for the stand alone fp switch, it cant be done. bypassing the fp relay will cause the distributor and other emission controls to act up. but thanks anyway!!!!
fordbuff8404 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Suzuki Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:47 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.13922 seconds with 37 queries