ZJ Stumbling lots - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old January 13th, 2006, 11:14 PM   #1
shawn
Resident HVAC/R Jambi
 
shawn's Avatar
 
Join Date: 11-05-05
Location: Milford/Commerce
Posts: 10,158
iTrader: (24)
Mentioned: 14 Post(s)
Send a message via Yahoo to shawn
Default ZJ Stumbling lots

I can't figure out what it may be. This 98 ZJ has the 318. It seems that whenever it is NOT at full operating temp, it stumbles terribly at part throttle, like going 20-50 mph. Feather the gas and it comes back alive, but otherwise rpms drop slow, and looses power, and even starts popping up threw the intake. I replaced the temp sensor, didn't help. It never gives and Engine Light no matter how bad it runs. I did get an SES light and it was the Speed sensor on the tranny, changed that but still didn't have anything to do with the crappy running. Anybody have any ideas? Map sensor maybe? Intake Air Temp sensor? I am at a loss.
shawn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old January 14th, 2006, 05:02 AM   #2
Yetti
Buy a Fiat! Save the UAW!
 
Yetti's Avatar
 
Join Date: 11-05-05
Location: 20 minutes south of Hell...
Posts: 14,388
iTrader: (10)
Mentioned: 2 Post(s)
Default

sounds like a plugged or jammed EGR valve. could be just a piece of carbon holding it open.
__________________
Yetti
Yetti is offline   Reply With Quote
Old January 14th, 2006, 11:55 AM   #3
shawn
Resident HVAC/R Jambi
 
shawn's Avatar
 
Join Date: 11-05-05
Location: Milford/Commerce
Posts: 10,158
iTrader: (24)
Mentioned: 14 Post(s)
Send a message via Yahoo to shawn
Default

No EGR on this one.
shawn is offline   Reply With Quote
Old March 6th, 2006, 08:06 PM   #4
shawn
Resident HVAC/R Jambi
 
shawn's Avatar
 
Join Date: 11-05-05
Location: Milford/Commerce
Posts: 10,158
iTrader: (24)
Mentioned: 14 Post(s)
Send a message via Yahoo to shawn
Default

I found my original thread. BTT.
shawn is offline   Reply With Quote
Old March 6th, 2006, 09:20 PM   #5
fr3db3ar
KISS MY AVATAR
 
fr3db3ar's Avatar
 
Join Date: 11-06-05
Location: Holland
Posts: 5,429
iTrader: (5)
Mentioned: 1 Post(s)
Send a message via ICQ to fr3db3ar Send a message via AIM to fr3db3ar Send a message via Yahoo to fr3db3ar
Default

Try the IAC Idle Air Controller....it's infamous. I just had to replace mine because I would gun it and let off.....die

back out of a parking spot let off...die.
fr3db3ar is offline   Reply With Quote
Old March 7th, 2006, 12:53 AM   #6
JEEPR
Playing Possum
 
JEEPR's Avatar
 
Join Date: 11-05-05
Location: Harrison Township
Posts: 6,744
iTrader: (9)
Mentioned: 0 Post(s)
Default

Tps?
JEEPR is offline   Reply With Quote
Old March 9th, 2006, 11:07 AM   #7
84Scrambler
Senior Member
 
Join Date: 11-07-05
Location: Lansing
Posts: 5,948
iTrader: (8)
Mentioned: 0 Post(s)
Send a message via AIM to 84Scrambler
Default

Shawn, I should have all three of the sensors on the TB out in the barn. I just have to find them. I can get them to you somehow, or you can head out to Dansville this weekend if you feel like going for a drive... I know I have the ones off the 5.9 you can use to see if one makes a difference. It could be a bad O2 sensor maybe?
84Scrambler is offline   Reply With Quote
Old March 9th, 2006, 11:17 AM   #8
shawn
Resident HVAC/R Jambi
 
shawn's Avatar
 
Join Date: 11-05-05
Location: Milford/Commerce
Posts: 10,158
iTrader: (24)
Mentioned: 14 Post(s)
Send a message via Yahoo to shawn
Default

Thanks man, I'll have to see where Dansville is. I will most likely be heading up to Fenton this weekend if you are up near there.
shawn is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:07 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10599 seconds with 46 queries