1998 ZJ running problems - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old March 6th, 2006, 06:36 PM   #1
shawn
Resident HVAC/R Jambi
 
shawn's Avatar
 
Join Date: 11-05-05
Location: Milford/Commerce
Posts: 9,992
iTrader: (24)
Mentioned: 3 Post(s)
Send a message via Yahoo to shawn
Unhappy 1998 ZJ running problems

I am at a loss. I can't figure this out. When it is not fully warmed up it runs like crap, idles like crap, and stumbles and sputters when accelarating at a light. If I start it and let it idle in park, while warming up it will start to idle very ruff, and the rpms will slowly drop. So yesterday, I let it warm up, I took off hte air horn, and watched what the IAC was doing, it would gradually open, and keep opening wich would make the motor run very lean and it would almost want to stall. So I stuck my finger in the IAC hole to plug it some, and it helped lots. Or if I 'jook' the gas then it will idle for a little bit then start stumbling again. When this thing is warmed up it seems to be much better.

What is telling the IAC what to do (besides the computer), what sensors effect the actions of the IAC? MAP, IAT? TPS?

I still need to check my belly pan gasket on the intake, that mat be a problem but it can't be all the problem.

Last edited by Sandals; March 11th, 2006 at 07:04 PM.
shawn is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old March 10th, 2006, 06:38 PM   #2
Andre1
Newbie
 
Join Date: 01-18-06
Location: Jackson
Posts: 7
iTrader: (0)
Mentioned: 0 Post(s)
Default

If you plug the IAC off and it runs better then you need to look for a vacuum leak. The engine should stall with the IAC pluged off. My brothers had a vacuum hose off at the vacuum acumulator (big plastic ball) that controls the heater controls. Good luck.
Andre1 is offline   Reply With Quote
Old March 10th, 2006, 08:59 PM   #3
shawn
Resident HVAC/R Jambi
 
shawn's Avatar
 
Join Date: 11-05-05
Location: Milford/Commerce
Posts: 9,992
iTrader: (24)
Mentioned: 3 Post(s)
Send a message via Yahoo to shawn
Default

Yeah, I tried that, I plugged it with my finger and it stalled. The problem is, until the motor is fully warmed up, something is telling the aic to open, it slowly opens until I have about 100 rpms. And then when you take off it won't close (I think).
shawn is online now   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:34 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.07583 seconds with 29 queries