Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old October 3rd, 2007, 06:58 PM   #1
montecarlo33
The Violator
 
montecarlo33's Avatar
 
Join Date: 08-23-07
Location: Otsego County 49735
Posts: 4,329
iTrader: (18)
Mentioned: 1 Post(s)
Default Trans problems....yeah another thread!

I got a 97 Dodge Ram 1/2 sport. It has the 5.2 and the 46RE trans. Its got a 134,000 miles on it. It was my girlfriends for a while. She bought it used so I dont know a whole lot about its history, execpt for it must have been used for towing something big, becuase there was a trailer brake mounted in the cab. Here's the scoop. It slips, gear hunts really bad. Its like it doesnt know where its gotta be. When its cold, it acts just fine. It throws a check engine light, and I had it read, its the speed sensor in the trans. The guy at Autozone suggested that might be what is causing it. Also the trans fluid smells burnt. I was thinking of having it just flushed and a new speed sensor installed, but when I took it to the trans shop, they wanted 40 bucks JUST TO LOOK AT IT! I really dont have the money to stick into a rebuilt trans right now. Do you think that would cause it? Does anyone know how much a speed sensor costs, or how much work is involved installing one? Everyone keeps telling me I probely need a rebuild, but it acts just fine when the truck is cold. Thanks for your help.
montecarlo33 is offline   Reply With Quote
Old October 3rd, 2007, 07:47 PM   #2
user name
keep your stick onthe ice
 
user name's Avatar
 
Join Date: 02-23-06
Location: around MI and such
Posts: 903
iTrader: (0)
Mentioned: 0 Post(s)
Default

I'm pretty sure that by 97 the speed sensor would be a pretty big player in the way your trans shifts. I would get that fixed and do a fluid change and band adjustment.
user name is offline   Reply With Quote
Old October 3rd, 2007, 08:02 PM   #3
montecarlo33
The Violator
 
montecarlo33's Avatar
 
Join Date: 08-23-07
Location: Otsego County 49735
Posts: 4,329
iTrader: (18)
Mentioned: 1 Post(s)
Default

Yeah thats what I figured too. When its cold the computer must be in Open loop, because when it warms up, it goes into close loop and all hell breaks loose. I just wonder how much a speed sensor is.....
montecarlo33 is offline   Reply With Quote
Old October 3rd, 2007, 08:02 PM   #4
GreaseMonkey
Senior Member
 
GreaseMonkey's Avatar
 
Join Date: 11-04-05
Location: Washington, MI
Posts: 17,955
iTrader: (22)
Mentioned: 1 Post(s)
Default

Please don't bitch about getting charged to get your truck looked at. Techs make their money by the job (flat rate), so if they take a half hour to an hour to look at your truck and then you don't want to do any work they still make some money.

I'd definitely do what user_name said.

I'd also have them look into some of the pressure switches as well. My 01 Ram 5.9L with the 46RE was doing a very similar thing minus the burnt fluid and that was the problem. They don't always throw a code either.
__________________
Quote:
Originally Posted by kerryann View Post
I am not a lesbian but if I was I would do her.
GreaseMonkey is offline   Reply With Quote
Old October 3rd, 2007, 08:08 PM   #5
montecarlo33
The Violator
 
montecarlo33's Avatar
 
Join Date: 08-23-07
Location: Otsego County 49735
Posts: 4,329
iTrader: (18)
Mentioned: 1 Post(s)
Default

Your right grease monkey.....My bad. I understand they need to make a living too. I guess I was use to my trans shop where I use to live in Gaylord, that would look at it, take it for a test ride, and hook it up to the computer for free, and they did awsome work. I didnt explain it, but the guy wouldnt even tell me the price of the speed sensor unless I payed him to look at it first. All I wanted was to find out some info on what the prices were. But I guess I will have to do some searchin around. Thanks!
montecarlo33 is offline   Reply With Quote
Old October 3rd, 2007, 08:47 PM   #6
GreaseMonkey
Senior Member
 
GreaseMonkey's Avatar
 
Join Date: 11-04-05
Location: Washington, MI
Posts: 17,955
iTrader: (22)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by montecarlo33 View Post
Your right grease monkey.....My bad. I understand they need to make a living too. I guess I was use to my trans shop where I use to live in Gaylord, that would look at it, take it for a test ride, and hook it up to the computer for free, and they did awsome work. I didnt explain it, but the guy wouldnt even tell me the price of the speed sensor unless I payed him to look at it first. All I wanted was to find out some info on what the prices were. But I guess I will have to do some searchin around. Thanks!
No problem. I didn't mean to come across so hard if it did come across that way.

Finding a shop like that in Gaylord is rare. Some shops that have high business and excellent reputations can do that. Others can't.

The dude not even telling you what the speed sensor would cost is crap. He could at least give you a general estimate of what it would cost to replace it, IF in fact it is the problem.

Good luck!
__________________
Quote:
Originally Posted by kerryann View Post
I am not a lesbian but if I was I would do her.
GreaseMonkey is offline   Reply With Quote
Old October 3rd, 2007, 09:06 PM   #7
montecarlo33
The Violator
 
montecarlo33's Avatar
 
Join Date: 08-23-07
Location: Otsego County 49735
Posts: 4,329
iTrader: (18)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by GreaseMonkey View Post
No problem. I didn't mean to come across so hard if it did come across that way.

Finding a shop like that in Gaylord is rare. Some shops that have high business and excellent reputations can do that. Others can't.

The dude not even telling you what the speed sensor would cost is crap. He could at least give you a general estimate of what it would cost to replace it, IF in fact it is the problem.

Good luck!
No your allright. Yeah I guess it was rare. The funny thing is that the Gaylord shop wasnt a big shop or anything. Yeah I just thought it was crap that he couldnt even tell me how much the parts were going to cost or anything. He just gave me the attitude that I didnt know what I was talking about, or what it needed. I just didnt want to pay him 40 bucks and have him turn back around and say "well you need a rebuild". I want to try and squeeze some more life outta this one...if possable.
montecarlo33 is offline   Reply With Quote
Old October 3rd, 2007, 10:34 PM   #8
GreaseMonkey
Senior Member
 
GreaseMonkey's Avatar
 
Join Date: 11-04-05
Location: Washington, MI
Posts: 17,955
iTrader: (22)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by montecarlo33 View Post
No your allright. Yeah I guess it was rare. The funny thing is that the Gaylord shop wasnt a big shop or anything. Yeah I just thought it was crap that he couldnt even tell me how much the parts were going to cost or anything. He just gave me the attitude that I didnt know what I was talking about, or what it needed. I just didnt want to pay him 40 bucks and have him turn back around and say "well you need a rebuild". I want to try and squeeze some more life outta this one...if possable.
Leave me a PM to remind me but I can look up the specs and repair procedure on All Data tomorrow so you know what you're doing.
__________________
Quote:
Originally Posted by kerryann View Post
I am not a lesbian but if I was I would do her.
GreaseMonkey is offline   Reply With Quote
Old October 5th, 2007, 04:17 PM   #9
montecarlo33
The Violator
 
montecarlo33's Avatar
 
Join Date: 08-23-07
Location: Otsego County 49735
Posts: 4,329
iTrader: (18)
Mentioned: 1 Post(s)
Default

Got it fixed today. It was the speed sensor, and they also did a tranny flush. I also had mud caked up by the kickdown linkage. She shifts like new, and no metal in the fuild!
montecarlo33 is offline   Reply With Quote
Old October 5th, 2007, 09:33 PM   #10
GreaseMonkey
Senior Member
 
GreaseMonkey's Avatar
 
Join Date: 11-04-05
Location: Washington, MI
Posts: 17,955
iTrader: (22)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by montecarlo33 View Post
Got it fixed today. It was the speed sensor, and they also did a tranny flush. I also had mud caked up by the kickdown linkage. She shifts like new, and no metal in the fuild!
Good deal.
__________________
Quote:
Originally Posted by kerryann View Post
I am not a lesbian but if I was I would do her.
GreaseMonkey is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:56 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.14681 seconds with 30 queries