Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Axle Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old May 22nd, 2012, 07:56 PM   #21
jroberts#77
Fuck there goes the trans
 
jroberts#77's Avatar
 
Join Date: 02-15-11
Location: milford mi
Posts: 253
iTrader: (0)
yeah it answered a lot of questions i had. great thread, cant let this get lost
jroberts#77 is online now   Reply With Quote
Old January 27th, 2013, 12:28 PM   #22
matthew
Newbie
 
Join Date: 01-27-13
Location: south carolina
Posts: 1
iTrader: (0)
I got a 83 chevy k30 with '77 1 ton axles under it, heres my problem... replaced the seal on one of the rear hubs, still leaking... cant find replacement hub or even the whole axle, what can i do? any alternatives? the hub is worn that even with a new seal its still leakin! please help!!!
matthew is offline   Reply With Quote
Old January 27th, 2013, 09:11 PM   #23
littletrucker
I'd hit that
 
littletrucker's Avatar
 
Join Date: 09-15-10
Location: Bear Lake 49614
Posts: 1,482
iTrader: (5)
That probably has a 14bolt rear end. Just replace it. probably one of the most readily available 1 ton rear ends. And even if you have a dana rear axle a 14 bolt should be a straight swap into a leaf sprung chevy.
littletrucker is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Axle Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:08 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.07324 seconds with 16 queries