Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Toyota Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old August 4th, 2007, 06:06 PM   #1
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,101
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default *grumble* fuel pump *grumble*

okay, so i dropped the money on a fuel pump, i've been told that the codes the motor is throwing means its running to lean, and its loosing lots of power.

so, fuel filter and pump great right?

$175 later, something is still broke because the fuel pump bracket the hoses on it we're rusty as shit and i fucking broke them... i also broke 4 of the 6 bolts off that hold the fucking tank in and i broke 3 of the bolts holding the skid plate on.... just not my day today at all.... *sigh*

tonight is my birthday party though, so i won't remember today :D

just ranting a little, sorry.


in good news, i start my new job monday at 10 am at the good year place in comstock park on alpine. :D they start at like 7.50 an hour, i hope i can use the tire machine's for free and get a huge discount.... hoping. who knows.
skife is offline   Reply With Quote
Old August 4th, 2007, 06:11 PM   #2
Pokerob
hug life
 
Pokerob's Avatar
 
Join Date: 10-25-06
Location: G-Rap, MI
Posts: 10,147
iTrader: (25)
Mentioned: 0 Post(s)
Default

Happy b-day man,
What type of vehicle?

Im right down the street from alpine, well sort of im about 2 miles east of the comstock vitalies. good to know some fellow GL4x4's in the n-hood.

btw if you get to use the tire machine for free you should hook me up and load my 33" x 12.5" claws on my 15" x 10" rims, if not cool. find out how much it cost there (discount said 80$ -lame-) and i will come up there and say whats up.

werd
-rob
Pokerob is offline   Reply With Quote
Old August 4th, 2007, 06:13 PM   #3
Haggar
Covered in mud...
 
Haggar's Avatar
 
Join Date: 11-06-05
Location: Oxford, MI
Posts: 17,557
iTrader: (54)
Mentioned: 1 Post(s)
Default

Yeah, my pump module developed a leak on one of those hard lines where it come out, too.

You have 3 options:

1) Buy a new one, they are $$$$$

2) Find a used one.

3) Repair it. Thats what I did. I cut off the old tube on both sides, and drilled out the hole a little bigger. I ran some larger hard line in through the hole and bent it to match the factory piece. I flared it so the hose would stay in placed. The other side I used flare fittings to connect to my other hard line. I sanded it very coursely, and used JB weld on both sides to seal that piece in there.

I had tried brazing it, but it was too much heat for the bits of rubber and the wiring connections in the plate (I had a scrap spare one to try it on first.).

Its worked fine for me since I did it.

Also, replace all of those screws with hex head stainless cap screws or hex bolts.
Haggar is offline   Reply With Quote
Old August 4th, 2007, 07:28 PM   #4
Mud'N'Truck
I'll Finsh One, One Day
 
Mud'N'Truck's Avatar
 
Join Date: 11-30-06
Location: Interlochen, Michigan
Posts: 2,339
iTrader: (15)
Mentioned: 1 Post(s)
Default

Good luck with that. Cant say ive had that problem. If it helps my 350 swap is being the biggest pain in the butt. Finally got it all mounted today though, motor, trans, and case just have to figure out a cross member for the case.
Good luck
Mud'N'Truck is offline   Reply With Quote
Old August 5th, 2007, 11:08 AM   #5
hunter2005
Senior Member
 
Join Date: 02-18-06
Location: BayCity/Michigan
Posts: 508
iTrader: (16)
Mentioned: 0 Post(s)
Default

i just order the same thing from the dealer with screws its 136.00 and just got to put my pump on it
hunter2005 is offline   Reply With Quote
Old August 5th, 2007, 11:35 AM   #6
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,101
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

well, i already replaced the screws with hex head screws.
another $136 will probably be fine, not sure lol. poker rob, if i can do mounting balancing for free, i'll definatally hook you up man.
yeah i was in yorkcreek last night. a few of my friends live there, i should have drank more but didn't. oh well.

the screws i pulled off the old peice i didn't even know they we're screws at first, i thought they we're bolts that we're all rounded off, i took half of them out with a 7mm socket. heh heh, the rest i twisted out with a pair of vice grips.

the line on mine is really rusty, i already tried to repair it with some JB weld putty and it didn't work so well. leaked like a siv...

thanks for the help guys, this is a dealer only item isn't it?
skife is offline   Reply With Quote
Old August 6th, 2007, 11:16 PM   #7
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,101
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

pokerrob, i might be able to mount and balance your tires, gimmie a few weeks of being there to get settled in.

first day on the job was cake :D
skife is offline   Reply With Quote
Old August 7th, 2007, 07:59 AM   #8
Haggar
Covered in mud...
 
Haggar's Avatar
 
Join Date: 11-06-05
Location: Oxford, MI
Posts: 17,557
iTrader: (54)
Mentioned: 1 Post(s)
Default

I've seen new ones on ebay before. Don't know if someone like napa could get one.
Haggar is offline   Reply With Quote
Old August 7th, 2007, 02:32 PM   #9
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,101
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

i checked with the asshole at the stealership today, he couldn't tell me if he had one in stock because i didn't have a VIN... i was like WTF do you need to know about the truck, i know pretty much everything he insisted he needed a vin. i've tried to deal with this guy before and he's an asshole.
bald guy at KOOL toyota on plainfield in Grand rapids.

he quoted me like $150ish though
skife is offline   Reply With Quote
Old August 31st, 2007, 10:32 AM   #10
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,101
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

think im going to try and repair it.

the guy at toyota grand rapids quoted me $255 :O
and the guy at KOOL toyota $167 and was pretty nice to me.
skife is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Toyota Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:47 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.11373 seconds with 30 queries