more questions about my dodge transmission - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old March 22nd, 2006, 10:04 PM   #1
4x4inAllDay
Dodge Father-Ram Daughter
 
4x4inAllDay's Avatar
 
Join Date: 11-09-05
Location: Utica, Mi
Posts: 240
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to 4x4inAllDay
Default more questions about my dodge transmission

as of right now i have stock gears 3.55 with 37" tires so yes iam expecting a loss of power and such but it wasnt as bad before i submerged my trans with water

ok so iam just wondering what you guys think of what its doing now...

when i take off from a dead stop 1/2 of the time it feels normal, 1/2 of the time it has like a serious loss of power it'll be revvin up to around 2500 before it even starts really movin, but if i mash on it it'll jump an go

once i get to any kind of speed, it never seems to slip at all it downshifts properly


now people have suggested torque converter --- plugged exhaust (catalytic) and other things... but iam wondering if a power flush from a shop might fix it ..... maybe still water in it? i dropped the pan myself about 9 times changing the fluid and filter to try adn get all the water out..
4x4inAllDay is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old March 23rd, 2006, 06:52 AM   #2
user name
keep your stick onthe ice
 
user name's Avatar
 
Join Date: 02-23-06
Location: around MI and such
Posts: 903
iTrader: (0)
Mentioned: 0 Post(s)
Default

i have been told once you get water in an auto trany they will probly be junk in a short time. I guess water acts with the glue on the bands and breaks it down. I had a blazer that i did a flush on after the cooler in the rad busted it slipped a little at times then poof no more moving that one went pretty fast
user name is offline   Reply With Quote
Old March 23rd, 2006, 08:21 AM   #3
Haggar
Covered in mud...
 
Haggar's Avatar
 
Join Date: 11-06-05
Location: Oxford, MI
Posts: 17,617
iTrader: (55)
Mentioned: 1 Post(s)
Default

If I understand right, you submerged the trans, and didn't completely drain and flush it?

Note what happened to Grandman's submerged trans a week ago, (behind a 5.2 magnum...)... its junk.

Having 3.55 gears and 37s is seriously overstressing the trans to begin with. Causes the fluid to really heat up. I would suspect that if you look at the fluid temps they would have been up above safe numbers anyway.
Haggar is offline   Reply With Quote
Old March 23rd, 2006, 10:40 AM   #4
PavementPounder
I am the law.
 
PavementPounder's Avatar
 
Join Date: 11-05-05
Location: Birmingham, Michigan 48009
Posts: 29,824
iTrader: (224)
Mentioned: 2 Post(s)
Default

Quote:
Originally Posted by 4x4inAllDay
i dropped the pan myself about 9 times changing the fluid and filter to try adn get all the water out..

That's like changing the oil by replacing only the amount held by your filter each time. I hydrolocked my Ram in a deep hole over a week ago and that trans has not been used since. I have no strawberry shake on the dipstick at all, but I still intend to be towed into an oil change shop bay for a power flush before I put it into any gear.

You may have already done yourself in, but from what you describe it sounds like the torque converter is not engaging correctly anymore, but finally locks up under heavier throttle.
PavementPounder is offline   Reply With Quote
Old March 23rd, 2006, 02:49 PM   #5
fr3db3ar
KISS MY AVATAR
 
fr3db3ar's Avatar
 
Join Date: 11-06-05
Location: Holland
Posts: 5,429
iTrader: (5)
Mentioned: 1 Post(s)
Send a message via ICQ to fr3db3ar Send a message via AIM to fr3db3ar Send a message via Yahoo to fr3db3ar
Default

Quote:
Originally Posted by Haggar
(behind a 5.2 magnum...)
Huh? :gman:
fr3db3ar is offline   Reply With Quote
Old March 23rd, 2006, 06:29 PM   #6
4x4inAllDay
Dodge Father-Ram Daughter
 
4x4inAllDay's Avatar
 
Join Date: 11-09-05
Location: Utica, Mi
Posts: 240
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to 4x4inAllDay
Default

when i said dropped the pan, (even though this is not good.. ) i did start it up and shift through the gears and get the fluid flowing all over .... i didnt just redump the same fluid i jus put in there....


Quote:
Originally Posted by PavementPounder
That's like changing the oil by replacing only the amount held by your filter each time. I hydrolocked my Ram in a deep hole over a week ago and that trans has not been used since. I have no strawberry shake on the dipstick at all, but I still intend to be towed into an oil change shop bay for a power flush before I put it into any gear.

You may have already done yourself in, but from what you describe it sounds like the torque converter is not engaging correctly anymore, but finally locks up under heavier throttle.
4x4inAllDay is offline   Reply With Quote
Old March 24th, 2006, 03:27 PM   #7
KILLER"B"468
Yankabilly
 
KILLER"B"468's Avatar
 
Join Date: 11-06-05
Location: Hendersonville Tn.
Posts: 7,945
iTrader: (19)
Mentioned: 1 Post(s)
Default

Your kick down lever spring may have fallen off. Allowing it to downshift some of the time. If you take off in manual low and upshift manually does it do it every time or still feels like it is slipping? You may have gotten lucky with the trans flushes, but I have only known 2 others to make it without having to be rebuilt. Those are pretty bad odds. If yours does survive, consider yourself lucky.
__________________
being on the eastern edge of the central time zone sucks...it gets dark WAY to early.

Quote:
Originally Posted by jeepbrattt View Post
An occasional jello or vasoline wrestling match isn't out of the question either.
KILLER"B"468 is offline   Reply With Quote
Old March 24th, 2006, 04:36 PM   #8
4x4inAllDay
Dodge Father-Ram Daughter
 
4x4inAllDay's Avatar
 
Join Date: 11-09-05
Location: Utica, Mi
Posts: 240
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to 4x4inAllDay
Default

Quote:
Originally Posted by KILLER"B&quot View Post
Your kick down lever spring may have fallen off. Allowing it to downshift some of the time. If you take off in manual low and upshift manually does it do it every time or still feels like it is slipping? You may have gotten lucky with the trans flushes, but I have only known 2 others to make it without having to be rebuilt. Those are pretty bad odds. If yours does survive, consider yourself lucky.

I got a full flush from a shop last nite and its been really great ever since.... <-- I hope!!
4x4inAllDay is offline   Reply With Quote
Old March 26th, 2006, 07:45 PM   #9
noodles
give 'er sh*t ay?
 
noodles's Avatar
 
Join Date: 11-07-05
Location: holland Mi
Posts: 1,029
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to noodles Send a message via MSN to noodles Send a message via Yahoo to noodles
Default

good to hear
noodles is offline   Reply With Quote
Old March 28th, 2006, 06:26 PM   #10
4x4inAllDay
Dodge Father-Ram Daughter
 
4x4inAllDay's Avatar
 
Join Date: 11-09-05
Location: Utica, Mi
Posts: 240
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to 4x4inAllDay
Default

aw well... kidna gettin worse


and this weird ass tick keeps getitn louder.. wtf mate
4x4inAllDay is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:39 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.18660 seconds with 52 queries