Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Tow rigs and trailers
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old May 22nd, 2007, 10:36 PM   #1
Big_Mack
Gotta love the BS
 
Big_Mack's Avatar
 
Join Date: 03-13-06
Location: Almont, Mi
Posts: 422
iTrader: (1)
Send a message via AIM to Big_Mack
electric brake controller on superduty

i have a superduty with a break controller that was installed before i bought the truck. i used to work great as well as the remote start that was also installed before my purchase. recently the remote started and the break controller quite working. when i plug in th trailer, the controller recognizes it and the manual slider works just not when i hit the pedal.

any advice?
Big_Mack is offline   Reply With Quote
Old May 22nd, 2007, 11:07 PM   #2
Buggy_Tim
(513) 891-8372
 
Buggy_Tim's Avatar
 
Join Date: 11-05-05
Location: Sault Sainte Marie
Posts: 11,616
iTrader: (12)
Sounds like someone did a hack and tap on the brake wire and now it's messed up.
Buggy_Tim is offline   Reply With Quote
Old May 22nd, 2007, 11:10 PM   #3
Kane
Got Jeep?
 
Kane's Avatar
 
Join Date: 11-07-05
Location: 48030
Posts: 587
iTrader: (4)
Quote:
Originally Posted by MuddyPaws View Post
Sounds like someone did a hack and tap on the brake wire and now it's messed up.
Thinking the same thing. Also, check to see that your brake lights are working, and fuses.
Kane is offline   Reply With Quote
Old May 23rd, 2007, 07:50 AM   #4
Viperdave
A-1 Dave Costa
 
Join Date: 03-12-06
Location: Wolcott, Ct
Posts: 1,106
iTrader: (2)
Send a message via AIM to Viperdave
his brake lights do work, which is why i also feel that the hack and tap was done on the feed wire for the brake controller
Viperdave is offline   Reply With Quote
Old May 23rd, 2007, 07:51 AM   #5
bigjay
The Man Myth And Legend
 
bigjay's Avatar
 
Join Date: 04-06-07
Location: i can piss on the allegan and barry county line at the same time.. ...
Posts: 5,120
iTrader: (1)
check the blinker fluid..i bet its low
bigjay is offline   Reply With Quote
Old May 23rd, 2007, 02:03 PM   #6
Big_Mack
Gotta love the BS
 
Big_Mack's Avatar
 
Join Date: 03-13-06
Location: Almont, Mi
Posts: 422
iTrader: (1)
Send a message via AIM to Big_Mack
so besides u guys thinkin its hacked together does anybody have any advice, should i try and find the wire that goes to the break switch, is that what u guys think it is.
Big_Mack is offline   Reply With Quote
Old May 23rd, 2007, 02:18 PM   #7
FORD FLARESIDE
Someday, yeah Someday
 
FORD FLARESIDE's Avatar
 
Join Date: 04-09-06
Location: Comstock Park
Posts: 20,705
iTrader: (23)
Quote:
Originally Posted by Big_Mack View Post
so besides u guys thinkin its hacked together does anybody have any advice, should i try and find the wire that goes to the break switch, is that what u guys think it is.
What year Superduty?

Check to see if it is a hack job or if they used the stock wiring.........maybe the plug is slightly disconnected.

The 99 to 2002, have a plug under the dash, almost behind the radio that came standard. This plug is a bear to get to, and may not have been connected properly.
Otherwise, its probably your controller.
FORD FLARESIDE is offline   Reply With Quote
Old May 23rd, 2007, 04:35 PM   #8
Big_Mack
Gotta love the BS
 
Big_Mack's Avatar
 
Join Date: 03-13-06
Location: Almont, Mi
Posts: 422
iTrader: (1)
Send a message via AIM to Big_Mack
its an 00 ill check for that plug thanks.
Big_Mack is offline   Reply With Quote
Old May 23rd, 2007, 06:16 PM   #9
Kane
Got Jeep?
 
Kane's Avatar
 
Join Date: 11-07-05
Location: 48030
Posts: 587
iTrader: (4)
Quote:
Originally Posted by FORD FLARESIDE View Post
What year Superduty?
The 99 to 2002, have a plug under the dash,
99 to current.
Kane is offline   Reply With Quote
Old May 23rd, 2007, 06:25 PM   #10
gmcpower98
Geocacher!!!!!!!!!!
 
gmcpower98's Avatar
 
Join Date: 02-26-06
Location: Grand Rapids, MI
Posts: 2,687
iTrader: (8)
check for corrosion on the plugs (truck end and trailer end).
I just repld the plug on mine $5 and 45 minutes.
Just make sure to disconnect the battery.
I shorted mine out and blew a fuse.
gmcpower98 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Tow rigs and trailers
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:45 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.13573 seconds with 30 queries