swaybar links - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old April 14th, 2007, 05:40 PM   #1
BigBlueBurban
Temporary Web Wheeler
 
BigBlueBurban's Avatar
 
Join Date: 04-15-06
Location: Grand Rapids
Posts: 128
iTrader: (0)
Mentioned: 0 Post(s)
Default swaybar links

anyone know how to remove the front swaybar links on a 1994 Burban 2500 4x4? there's a nut on the top that i try to loosen, but all it does is spin and spin and spin and spin and spin. The bottom of the swaybar link goes through the lower a-arm and on the bottom of the a-arm is a plastic circle that looks like its popped in. However i can't get the plastic piece to move to tell whether or not there is a nut/bolt on the other side that i need to stop from moving while i loosen the top one. if any of that was confusing, just let me know and i'll snap a few pics and throw em up to show you what im talking about.
BigBlueBurban is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old April 14th, 2007, 06:19 PM   #2
Yetti
Buy a Fiat! Save the UAW!
 
Yetti's Avatar
 
Join Date: 11-05-05
Location: 20 minutes south of Hell...
Posts: 14,384
iTrader: (10)
Mentioned: 2 Post(s)
Default

they should be just a normal bolt bushing set up. GM used shrink wrap around the center section so they would stay together durring assembly. most likely they are just rusty as heck and you can't find the one end to hold it. cut'em off and buy new.
__________________
Yetti
Yetti is offline   Reply With Quote
Old April 15th, 2007, 03:29 PM   #3
BigBlueBurban
Temporary Web Wheeler
 
BigBlueBurban's Avatar
 
Join Date: 04-15-06
Location: Grand Rapids
Posts: 128
iTrader: (0)
Mentioned: 0 Post(s)
Default

the one that i've been trying to remove wasn't replaced all that long ago. had to do an emergency evasion and heard a huge pop in the inside of my fender well. it was the top of the swaybar link shooting off. so it was replaced probably only a year or so ago. they otherside, yes, most likely is rusted in place. i guess i'll try and take off those plastic bottom caps in the a-arms and see if there r any bolts in there. if not, then suppose ill just cut 'em
BigBlueBurban is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:26 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.11088 seconds with 29 queries