2.9L problem - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old March 27th, 2007, 03:54 PM   #1
drew15
Member
 
Join Date: 11-22-06
Location: Canada, LaSalle
Posts: 55
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via MSN to drew15
Default 2.9L problem

hey i drove home from school and i saw that my truck was leaking oil so i went to start it to put it on the ramps becasue it wont start. the fuel pumps come on and i have power but when i turn the key all the way i have nothing it is making no noise or nother. i turn it one click and the pumps come and then i go to turn and on and nothing. i think that my motor seased up but i dont know if anyone know what it is or soemone can come over and help me that would be nice. email me at andrewandy49@hotmail.com or call andrew at 519-969-1502 later drew
drew15 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old March 27th, 2007, 04:13 PM   #2
Buggy_Tim
(513) 891-8372
 
Buggy_Tim's Avatar
 
Join Date: 11-05-05
Location: Sault Sainte Marie
Posts: 11,823
iTrader: (12)
Mentioned: 3 Post(s)
Default

Blown fuse link?
Buggy_Tim is offline   Reply With Quote
Old March 27th, 2007, 06:29 PM   #3
Gr8wht2000GMC
Senior Member
 
Gr8wht2000GMC's Avatar
 
Join Date: 12-25-06
Location: Bellevue Mi
Posts: 247
iTrader: (1)
Mentioned: 0 Post(s)
Default

dirty cables?
Gr8wht2000GMC is offline   Reply With Quote
Old March 27th, 2007, 07:34 PM   #4
88mudder
In the band!
 
Join Date: 03-30-06
Location: waterford michigan
Posts: 3,678
iTrader: (29)
Mentioned: 0 Post(s)
Send a message via AIM to 88mudder Send a message via Skype™ to 88mudder
Default

post on www.therangerstation.com , there's way more ppl on there who can help u out more.

Last edited by 88mudder; April 1st, 2007 at 10:03 AM.
88mudder is offline   Reply With Quote
Old March 29th, 2007, 08:45 PM   #5
drew15
Member
 
Join Date: 11-22-06
Location: Canada, LaSalle
Posts: 55
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via MSN to drew15
Default

hey i dont havea anem on there is it wont let me get a name so if someone can post sometinhg for me that would be good
later drew
drew15 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:02 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10935 seconds with 35 queries