Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old January 25th, 2007, 12:38 PM   #1
signman
Member
 
Join Date: 11-19-06
Location: harrision/ mich
Posts: 74
iTrader: (0)
Spedo problem

Any body have a good fix for a 04, spedo goes up but won,t go back down unless you start and stop the motor several times
signman is offline   Reply With Quote
Old January 25th, 2007, 05:07 PM   #2
Yetti
Buy a Fiat! Save the UAW!
 
Yetti's Avatar
 
Join Date: 11-05-05
Location: 20 minutes south of Hell...
Posts: 14,382
iTrader: (10)
the speedo is electricly drivin so if its not coming down the clutser would have to be removed and sent to specmo for repair
__________________
Yetti
Yetti is offline   Reply With Quote
Old January 25th, 2007, 07:07 PM   #3
AWK
Senior Member
 
AWK's Avatar
 
Join Date: 11-15-05
Location: Chesterfield
Posts: 626
iTrader: (3)
04's have a huge issue with stepper motors. In fact you may find that the cluster is on back order at the dealer. If you have access to a Tech 2 it would be easy to find.

Doesn't Jesus do clusters for GM? He should know.

AWK
AWK is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:01 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.06462 seconds with 16 queries