WJ: Tranny Tran Trans - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old August 13th, 2014, 09:57 AM   #1
Sandals
Fucking Zen as Shit
 
Sandals's Avatar
 
Join Date: 11-05-05
Location: Lindenhurst, IL
Posts: 15,399
iTrader: (7)
Mentioned: 3 Post(s)
Default Tranny Tran Trans

2001 WJ Limited, 4.7 auto trans

18 months ago, had Trans rebuilt and TC replaced, seemed fine for a bit, and started having previous issues again, Some slipping at highway speed (gears) occasional hard and late shifting. They took it back, looked into, made a few small adjustments but didn't find anything obvious.

Still having issues, but it's only intermittent. Not constant at all, and sometimes a shut off and cycling makes the issue go away which is making think it's possibly the transmission electronics.

Anyone else have a take on this? If i was able to easily find a Junkyard box (Haven't been able to) I would swap it and see if that cures it, but looks like only option is a new replacement and would rather noth spend a few hundred on that if it's still a mechanical issue.

My Knowledge on auto trans is limited, hence why i'm reaching out.
Sandals is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old August 13th, 2014, 08:34 PM   #2
Tranny Tom
Switcheroo
 
Tranny Tom's Avatar
 
Join Date: 10-13-06
Location: Southfield
Posts: 3,824
iTrader: (55)
Mentioned: 10 Post(s)
Default

No codes? How is the tps? Unfortunately there are lots of engine electronics that can cause the trans to act wacky. My guess is a problem in the valve body. They have a problem with an accumulator plate cracking.
Tranny Tom is offline   Reply With Quote
Old August 13th, 2014, 11:25 PM   #3
Sandals
Fucking Zen as Shit
 
Sandals's Avatar
 
Join Date: 11-05-05
Location: Lindenhurst, IL
Posts: 15,399
iTrader: (7)
Mentioned: 3 Post(s)
Default

Quote:
Originally Posted by Tranny Tom View Post
No codes? How is the tps? Unfortunately there are lots of engine electronics that can cause the trans to act wacky. My guess is a problem in the valve body. They have a problem with an accumulator plate cracking.
No Codes (aside from ABS but fukc those 3 sensors)


TPS Seems fine, have yet to replace, I could, it's old enough but i almost always break one of those fucking screws.

I'm guessing valve body isn't an "in the vehicle repair" a mildly knowledgeable person can do themselves is it?
Sandals is offline   Reply With Quote
Old August 26th, 2014, 11:21 AM   #4
ricthewrench
i make everything
 
Join Date: 11-11-09
Location: ortonville,mi
Posts: 329
iTrader: (17)
Mentioned: 0 Post(s)
Default

listen to tom, guru status.
ricthewrench is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:17 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.09626 seconds with 32 queries