Ford 6.7 Charging issues.......look here - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old May 8th, 2014, 10:41 AM   #1
frdboy
Wishin' I waz fishin'
 
frdboy's Avatar
 
Join Date: 03-29-06
Location: Grand Haven, MI
Posts: 10,913
iTrader: (25)
Mentioned: 9 Post(s)
Default Ford 6.7 Charging issues.......look here

Thought I would post this here to maybe help someone out down the road

Had my first 6.7 in the shop today.....2011, 80K miles

Came in with the battery light on although it was still charging......had a code P0625 (Generator Field Terminal Circuit Low)



I found what I think will be a common problem unless they fixed it in the later years, Ford ran the alternator control wires in a plastic holder with the a heavy power and ground cable.......heavy cable lays on top of little wires, rubs through the insulation and wire corrodes.








I decided instead of fixing the one bad wire and having another issue with this truck later I would replace all three wires and run them separate from the heavy ones. I used a 3 wire with heavy insulation.



__________________
Cheap Thrills Off Road

2003 F-250 4X4 7.3 PSD Crew Cab

1971 Bronco
frdboy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old May 8th, 2014, 10:43 AM   #2
xj4life
Senior Member
 
xj4life's Avatar
 
Join Date: 11-09-05
Location: LaPorte, IN
Posts: 7,770
iTrader: (15)
Mentioned: 2 Post(s)
Default

love the attention to detail. dont just fix the superficial issue, find the root cause and fix that.
__________________
This is my Jeep. There are many like it, but this one is mine. My Jeep is my best friend. It is my life. I must master it as I master my life. My Jeep, without me, is useless. Without my Jeep, I am useless.
xj4life is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:40 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.08616 seconds with 26 queries