Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old April 8th, 2014, 10:42 AM   #1
kchittle12
Newbie
 
kchittle12's Avatar
 
Join Date: 02-26-14
Location: twin lake mi
Posts: 15
iTrader: (0)
Mentioned: 0 Post(s)
Default xj rolls over but wont start help

my 98 xj started up just fine and when i went to leave it just shut off on me.. now when i turn the key it rolls over but wont actually start.. i think its the crankshaft sensor... what does everyone think
kchittle12 is offline   Reply With Quote
Old April 8th, 2014, 10:45 AM   #2
Hi Im Adam
Senior Member
 
Join Date: 08-19-10
Location: Muskegon, MI
Posts: 297
iTrader: (3)
Mentioned: 0 Post(s)
Default

I think you're spot on.
Hi Im Adam is offline   Reply With Quote
Old April 8th, 2014, 10:46 AM   #3
GREASYHANDS
wabbit season
 
GREASYHANDS's Avatar
 
Join Date: 03-16-09
Location: Ravenna
Posts: 12,463
iTrader: (28)
Mentioned: 11 Post(s)
Default

Guessing costs extra
__________________
Quote:
Originally Posted by RookieMT View Post
sorry I don't work on fords I park on top of them!
Bare Bones Offroad
RIP FS4L
Pavement sucks
Meow
GREASYHANDS is offline   Reply With Quote
Old April 8th, 2014, 10:47 AM   #4
Immortal
NO RELIGION WAT!
 
Immortal's Avatar
 
Join Date: 11-09-05
Location: In my garage
Posts: 25,199
iTrader: (45)
Mentioned: 48 Post(s)
Default

I would suspect neutral safety switch.
While in park row through the gears once or twice.
Put it back in park and firmly keep forward pressure on the shifter and see if it starts.
Immortal is offline   Reply With Quote
Old April 8th, 2014, 10:48 AM   #5
Lousypirate
Yo
 
Lousypirate's Avatar
 
Join Date: 02-11-08
Location: Norton Shores 49441
Posts: 10,428
iTrader: (31)
Mentioned: 23 Post(s)
Default

http://www.cherokeeforum.com/f67/98-...oblems-121516/
__________________
2003 gmc 1500hd quadrasteer "Miley"
2000 jeep cherokee "Herman"
1977 Ranger 150a bass boat
1987 Yamaha Moto 4 quad
Lousypirate is online now   Reply With Quote
Old April 8th, 2014, 01:07 PM   #6
kchittle12
Newbie
 
kchittle12's Avatar
 
Join Date: 02-26-14
Location: twin lake mi
Posts: 15
iTrader: (0)
Mentioned: 0 Post(s)
Default

i tried running thru the gears so i know its not my neutral safety switch..
just didnt know what else it could be
kchittle12 is offline   Reply With Quote
Old April 8th, 2014, 01:48 PM   #7
Immortal
NO RELIGION WAT!
 
Immortal's Avatar
 
Join Date: 11-09-05
Location: In my garage
Posts: 25,199
iTrader: (45)
Mentioned: 48 Post(s)
Default

If you have spark then cam positioning sensor.
Swap it out with a used one to test it.
Immortal is offline   Reply With Quote
Old April 8th, 2014, 01:56 PM   #8
bigbchevy
missmrgreenagain
 
bigbchevy's Avatar
 
Join Date: 09-15-07
Location: fenton /hartland mi
Posts: 18,525
iTrader: (163)
Mentioned: 36 Post(s)
Default

Quote:
Originally Posted by GREASYHANDS View Post
Guessing costs extra
__________________
H.o.r.e
(mr.green)So you are calling CC a liar?? Not a nice way to treat your bitch.
tube bending and gear installs pm me for info! gears installed for $150 and up per axle.
bigbchevy is offline   Reply With Quote
Old April 8th, 2014, 02:49 PM   #9
Immortal
NO RELIGION WAT!
 
Immortal's Avatar
 
Join Date: 11-09-05
Location: In my garage
Posts: 25,199
iTrader: (45)
Mentioned: 48 Post(s)
Default

Quote:
Originally Posted by GREASYHANDS View Post
Guessing costs extra
I don't care. Not my money if the guy spends it on new parts

I'm 99% positive it is the cps or the fuel pump
Immortal is offline   Reply With Quote
Old April 8th, 2014, 03:16 PM   #10
Dylan
Senior Member
 
Dylan's Avatar
 
Join Date: 08-24-06
Location: K-zoo
Posts: 1,117
iTrader: (7)
Mentioned: 0 Post(s)
Default

why not test it before you just buy parts.

1st off, bad NSS = no crank. Not no start

check for spark at a plug. If you get spark, then spray started fluid down the intake. It should run. If no spark, it could be crank or cam. More likely crank sensor.

If you have a scanner, read the live RPM as you crank. If nothing than bad crank sensor.

If it runs on spray and dies, check fuel pump relay and fuel pump by jumping wires. All that should be free or next to free to test.
Dylan is offline   Reply With Quote
Old April 8th, 2014, 03:29 PM   #11
Immortal
NO RELIGION WAT!
 
Immortal's Avatar
 
Join Date: 11-09-05
Location: In my garage
Posts: 25,199
iTrader: (45)
Mentioned: 48 Post(s)
Default

Quote:
Originally Posted by Dylan View Post
why not test it before you just buy parts.
yes

1st off, bad NSS = no crank. Not no start
oops....forgot

check for spark at a plug. If you get spark, then spray started fluid down the intake. It should run. If no spark, it could be crank or cam. More likely crank sensor.
I still think cam, but how can you tell if it's either or. I got a used cps from a yard and put that on my 98 and it fixed it.

If you have a scanner, read the live RPM as you crank. If nothing than bad crank sensor.

If it runs on spray and dies, check fuel pump relay and fuel pump by jumping wires. All that should be free or next to free to test.
Immortal is offline   Reply With Quote
Old April 9th, 2014, 08:59 AM   #12
kchittle12
Newbie
 
kchittle12's Avatar
 
Join Date: 02-26-14
Location: twin lake mi
Posts: 15
iTrader: (0)
Mentioned: 0 Post(s)
Default

Just changed the crank sensor and still nothing and it is getting fuel
I'll have to check and see if I have spark from the plugs or not
kchittle12 is offline   Reply With Quote
Old April 9th, 2014, 09:13 AM   #13
Immortal
NO RELIGION WAT!
 
Immortal's Avatar
 
Join Date: 11-09-05
Location: In my garage
Posts: 25,199
iTrader: (45)
Mentioned: 48 Post(s)
Default

Shit I meant cam sensor (cps) in the distributor.
Immortal is offline   Reply With Quote
Old April 9th, 2014, 11:54 AM   #14
firehawk
Live Action!
 
firehawk's Avatar
 
Join Date: 10-02-07
Location: Clawson, Michigan
Posts: 12,269
iTrader: (44)
Mentioned: 6 Post(s)
Default

It wants its belly rubbed when it rolls over
firehawk is offline   Reply With Quote
Old April 9th, 2014, 01:21 PM   #15
kchittle12
Newbie
 
kchittle12's Avatar
 
Join Date: 02-26-14
Location: twin lake mi
Posts: 15
iTrader: (0)
Mentioned: 0 Post(s)
Default

it doesnt have a cam sensor
going to see if i get spark tomorrow morning
kchittle12 is offline   Reply With Quote
Old April 9th, 2014, 02:29 PM   #16
GREASYHANDS
wabbit season
 
GREASYHANDS's Avatar
 
Join Date: 03-16-09
Location: Ravenna
Posts: 12,463
iTrader: (28)
Mentioned: 11 Post(s)
Default

It has a cam sensor
__________________
Quote:
Originally Posted by RookieMT View Post
sorry I don't work on fords I park on top of them!
Bare Bones Offroad
RIP FS4L
Pavement sucks
Meow
GREASYHANDS is offline   Reply With Quote
Old April 9th, 2014, 02:39 PM   #17
Immortal
NO RELIGION WAT!
 
Immortal's Avatar
 
Join Date: 11-09-05
Location: In my garage
Posts: 25,199
iTrader: (45)
Mentioned: 48 Post(s)
Default

Quote:
Originally Posted by kchittle12 View Post
it doesnt have a cam sensor
going to see if i get spark tomorrow morning
Quote:
Originally Posted by GREASYHANDS View Post
It has a cam sensor
He said it doesn't.
Immortal is offline   Reply With Quote
Old April 10th, 2014, 09:26 AM   #18
kchittle12
Newbie
 
kchittle12's Avatar
 
Join Date: 02-26-14
Location: twin lake mi
Posts: 15
iTrader: (0)
Mentioned: 0 Post(s)
Default

Lost it has no spark and when I hook it up to the coil it also has no spark
Could it be a bad coil
kchittle12 is offline   Reply With Quote
Old April 10th, 2014, 09:27 AM   #19
dirtydude
Member
 
dirtydude's Avatar
 
Join Date: 03-18-13
Location: Michigan
Posts: 86
iTrader: (0)
Mentioned: 1 Post(s)
Default

Hit the starter with a hammer
dirtydude is offline   Reply With Quote
Old April 10th, 2014, 09:27 AM   #20
dirtydude
Member
 
dirtydude's Avatar
 
Join Date: 03-18-13
Location: Michigan
Posts: 86
iTrader: (0)
Mentioned: 1 Post(s)
Default

It'll start
dirtydude is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:42 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.17418 seconds with 50 queries