2000 ram van 3500 HELP - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old April 5th, 2014, 08:31 PM   #1
eagle-eye
Senior Member
 
Join Date: 01-21-10
Location: Holly, MI
Posts: 423
iTrader: (3)
Mentioned: 0 Post(s)
Default 2000 ram van 3500 HELP

The van has a 5.9 engine and auto trans. The problem is that the brake and abs lights are lit, relays click like crazy and the fuel pump runs continuously. All of this is while the key is on engine off. The engine will barely start let alone run. I pulled the trans harness off( the 3 wire plug on the driver side) and there is corrosion/dirt in it. I am thinking a bad ecm as this is what these vans are known for.

What do yall think?
If it is a bad ecm, could the trans plug have cause it?
If this doesnt sound right, what do i test?
What are the relays in the interior fuse box as the plate doesnt tell me.

Thanks in advance!
eagle-eye is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old April 7th, 2014, 11:05 PM   #2
blackbronco92
300 Inline 6
 
blackbronco92's Avatar
 
Join Date: 01-28-09
Location: Grand Rapids, MI
Posts: 479
iTrader: (1)
Mentioned: 0 Post(s)
Default

I would definitely point towards a toasted ECM with those symptoms.

Any corroded connections *could* short out the ECM, but I wouldn't suspect the trans. harness. It's possible, but most likely you had corrosion issues in the ECM itself which is most common. However, I'd clean up any connections I can before hooking up the next ECM. Good Luck!
blackbronco92 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:38 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.07304 seconds with 26 queries