v10 2 valve low oil pressure - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old March 4th, 2014, 05:27 PM   #1
in2deep
Hole tester
 
Join Date: 05-06-10
Location: muskegon,mi
Posts: 1,273
iTrader: (3)
Mentioned: 1 Post(s)
Default v10 2 valve low oil pressure

while driving I lost all oil pressure I shut it down and got it dragged home. I don't have much experience with ford is this a common problem? it only has a few hundred miles since last service. but I going to change the filter for shits and the oil while im at it, be for this the truck had good pressure.
in2deep is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old March 5th, 2014, 05:57 AM   #2
frdboy
Wishin' I waz fishin'
 
frdboy's Avatar
 
Join Date: 03-29-06
Location: Grand Haven, MI
Posts: 10,938
iTrader: (25)
Mentioned: 9 Post(s)
Default

How many miles on the truck? Are you sure it lost pressure and not just a gauge issue?

Not common.
__________________
Cheap Thrills Off Road

2003 F-250 4X4 7.3 PSD Crew Cab

1971 Bronco
frdboy is offline   Reply With Quote
Old March 5th, 2014, 06:53 AM   #3
CheapThrillB2
FAWK YEAH!!
 
CheapThrillB2's Avatar
 
Join Date: 09-06-06
Location: Middleville, MI
Posts: 31,291
iTrader: (61)
Mentioned: 10 Post(s)
Default

X2, check oil sender. Could of just failed.
CheapThrillB2 is offline   Reply With Quote
Old March 5th, 2014, 08:28 AM   #4
in2deep
Hole tester
 
Join Date: 05-06-10
Location: muskegon,mi
Posts: 1,273
iTrader: (3)
Mentioned: 1 Post(s)
Default

150k hard miles and its been neglected. not a gage issue it really has no oil pressure dosnt even fill the filter.
in2deep is offline   Reply With Quote
Old March 7th, 2014, 06:49 PM   #5
in2deep
Hole tester
 
Join Date: 05-06-10
Location: muskegon,mi
Posts: 1,273
iTrader: (3)
Mentioned: 1 Post(s)
Default

any idea if I have to pull the engine or if I can do it in the truck?
in2deep is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:34 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.08574 seconds with 37 queries