99 tj 4.0 auto no balls?? - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old November 22nd, 2013, 08:09 PM   #1
snocross2xtremes
Senior Member
 
snocross2xtremes's Avatar
 
Join Date: 11-27-05
Location: brighton or Fenton
Posts: 6,558
iTrader: (69)
Mentioned: 3 Post(s)
Send a message via AIM to snocross2xtremes
Default 99 tj 4.0 auto no balls??

99 tj 4.0 auto sport 3:73 gear

Good compression

33" tire

The jeep just has no power when ya step on it

No check engine light..
snocross2xtremes is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old November 22nd, 2013, 08:12 PM   #2
jbsjunk
Wheelies
 
jbsjunk's Avatar
 
Join Date: 03-01-08
Location: Almost Allendale Mi
Posts: 16,855
iTrader: (36)
Mentioned: 20 Post(s)
Default

Have all the gears? Low speed or highway no power?
jbsjunk is offline   Reply With Quote
Old November 22nd, 2013, 08:29 PM   #3
firehawk
Live Action!
 
firehawk's Avatar
 
Join Date: 10-02-07
Location: Clawson, Michigan
Posts: 12,862
iTrader: (43)
Mentioned: 20 Post(s)
Default

All stock or has the motor or trans been swapped?

Plugged cat?
firehawk is offline   Reply With Quote
Old November 22nd, 2013, 10:06 PM   #4
marshall
locally famous
 
marshall's Avatar
 
Join Date: 02-12-11
Location: mayville MI
Posts: 3,208
iTrader: (4)
Mentioned: 1 Post(s)
Default

Try these


Benwa balls

I have five linked medium benwa balls only used twice...I bought them for the wife and she didn't care for them, so I tried them once. I can honestly say they weren't for me either. My loss your gain. $75 obo. I know people that like them really like them, I just couldn't get used to them. Maybe I need small ones?
marshall is offline   Reply With Quote
Old November 23rd, 2013, 12:55 AM   #5
snocross2xtremes
Senior Member
 
snocross2xtremes's Avatar
 
Join Date: 11-27-05
Location: brighton or Fenton
Posts: 6,558
iTrader: (69)
Mentioned: 3 Post(s)
Send a message via AIM to snocross2xtremes
Default

Quote:
Originally Posted by jbsjunk View Post
Have all the gears? Low speed or highway no power?
As far as I know yes.

Quote:
Originally Posted by firehawk View Post
All stock or has the motor or trans been swapped?

Plugged cat?
Not that I can tell but I do wanna change it
snocross2xtremes is offline   Reply With Quote
Old November 23rd, 2013, 08:31 AM   #6
Dylan
Senior Member
 
Dylan's Avatar
 
Join Date: 08-24-06
Location: K-zoo
Posts: 1,127
iTrader: (7)
Mentioned: 0 Post(s)
Default

off the line or when you're trying to downshift? Mine had an issue of starting off in second off the line so it was gutless. Sticky gov. Try putting it in the gears manually and see if it makes a difference. If its not downshifting than TV cable? If it is downshifting but still slow, it may have to do with 33 and 3.73 lol.
Dylan is offline   Reply With Quote
Old November 23rd, 2013, 05:04 PM   #7
jeepers48
Senior Member
 
jeepers48's Avatar
 
Join Date: 07-05-06
Location: Auburn Hills MI
Posts: 4,822
iTrader: (106)
Mentioned: 1 Post(s)
Default

X2 on the cat.
If it still has the catalytic convertor on it/ may be clogged? Had it happen on a ford once. had no balls till I cut the pipe to find out. Made a big difference.
jeepers48 is online now   Reply With Quote
Old November 23rd, 2013, 06:26 PM   #8
jbsjunk
Wheelies
 
jbsjunk's Avatar
 
Join Date: 03-01-08
Location: Almost Allendale Mi
Posts: 16,855
iTrader: (36)
Mentioned: 20 Post(s)
Default

If there is a pre cat O2, you can pull it out and see if it works better and check for a plugged cat.
jbsjunk is offline   Reply With Quote
Old November 23rd, 2013, 07:10 PM   #9
revdog
Senior Member
 
Join Date: 07-29-12
Location: chelsea mi
Posts: 206
iTrader: (2)
Mentioned: 0 Post(s)
Default

I'd pull the o2 and see if it picks up power. Did yas check fuel pressure? Weres the initial timing set?

Sent from my DROID RAZR using Tapatalk 2
revdog is online now   Reply With Quote
Old November 23rd, 2013, 07:25 PM   #10
Rob the plumber
Licensed master plumber
 
Rob the plumber's Avatar
 
Join Date: 06-14-06
Location: New Baltimore, Michigan
Posts: 5,794
iTrader: (34)
Mentioned: 2 Post(s)
Default

You can't adjust initial timing on a 4.0.
Rob the plumber is offline   Reply With Quote
Old November 23rd, 2013, 08:27 PM   #11
revdog
Senior Member
 
Join Date: 07-29-12
Location: chelsea mi
Posts: 206
iTrader: (2)
Mentioned: 0 Post(s)
Default

But you can see where its at.

Sent from my DROID RAZR using Tapatalk 2
revdog is online now   Reply With Quote
Old November 23rd, 2013, 10:03 PM   #12
Rob the plumber
Licensed master plumber
 
Rob the plumber's Avatar
 
Join Date: 06-14-06
Location: New Baltimore, Michigan
Posts: 5,794
iTrader: (34)
Mentioned: 2 Post(s)
Default

There is a marker on the timing cover isn't there?
Rob the plumber is offline   Reply With Quote
Old November 24th, 2013, 06:34 PM   #13
snocross2xtremes
Senior Member
 
snocross2xtremes's Avatar
 
Join Date: 11-27-05
Location: brighton or Fenton
Posts: 6,558
iTrader: (69)
Mentioned: 3 Post(s)
Send a message via AIM to snocross2xtremes
Default

gonna check the cat next.
snocross2xtremes is offline   Reply With Quote
Old November 24th, 2013, 07:35 PM   #14
firehawk
Live Action!
 
firehawk's Avatar
 
Join Date: 10-02-07
Location: Clawson, Michigan
Posts: 12,862
iTrader: (43)
Mentioned: 20 Post(s)
Default

Quote:
Originally Posted by snocross2xtremes View Post
gonna check the cat next.
Meow?
firehawk is offline   Reply With Quote
Old November 24th, 2013, 07:57 PM   #15
bigbchevy
missmrgreenagain
 
bigbchevy's Avatar
 
Join Date: 09-15-07
Location: fenton /hartland mi
Posts: 20,067
iTrader: (167)
Mentioned: 85 Post(s)
Default

Nuts
__________________
H.o.r.e
(mr.green)So you are calling CC a liar?? Not a nice way to treat your bitch.
tube bending and gear installs pm me for info! gears installed for $150 and up per axle.
bigbchevy is online now   Reply With Quote
Old November 24th, 2013, 10:32 PM   #16
Wehan
Senior Member
 
Wehan's Avatar
 
Join Date: 10-07-06
Location: Charlotte, MI
Posts: 2,801
iTrader: (25)
Mentioned: 2 Post(s)
Default

I know it sounds obvious but did you check the air filter? Next easiest would be fuel pressure and then the fuel filter then the cat.
__________________

Last edited by Wehan; November 24th, 2013 at 11:36 PM.
Wehan is online now   Reply With Quote
Old November 25th, 2013, 10:54 PM   #17
snocross2xtremes
Senior Member
 
snocross2xtremes's Avatar
 
Join Date: 11-27-05
Location: brighton or Fenton
Posts: 6,558
iTrader: (69)
Mentioned: 3 Post(s)
Send a message via AIM to snocross2xtremes
Default

Quote:
Originally Posted by Wehan View Post
I know it sounds obvious but did you check the air filter? Next easiest would be fuel pressure and then the fuel filter then the cat.
air filter is new. have not check fuel psi yet.
snocross2xtremes is offline   Reply With Quote
Old November 27th, 2013, 01:22 PM   #18
idiot magnet
Member
 
idiot magnet's Avatar
 
Join Date: 12-06-12
Location: Mackinaw City, MI
Posts: 93
iTrader: (0)
Mentioned: 0 Post(s)
Default

My cat busted apart and plugged up the muffler and did the same thing that you are describing.
idiot magnet is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:42 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.23915 seconds with 74 queries