ZJ: 98 Grand Cherokee, trans shift problem. (Video included) - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old October 28th, 2013, 09:40 PM   #1
Badmunky
Senior Member
 
Badmunky's Avatar
 
Join Date: 04-22-13
Location: Michigan (South East)
Posts: 191
iTrader: (1)
Mentioned: 0 Post(s)
Question 98 Grand Cherokee, trans shift problem. (Video included)

I have a problem with our 98 GC.
The trans is not shifting right when you drive it normally. But shifts fine when you hammer on it or drive it like grandma.

Here is a link to a video of the problem.

There is some more info in the video as well.

So what do you guys think the problem is?
Badmunky is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old October 29th, 2013, 04:29 AM   #2
big86inthestixx
Senior Member
 
big86inthestixx's Avatar
 
Join Date: 04-30-11
Location: howard city Mi
Posts: 2,369
iTrader: (9)
Mentioned: 3 Post(s)
Default

Seems like a governor pressure solenoid to me. What trans, 42re, 45rfe?
Does it act up more as the trans gets up to temp? Seems fine when cold?

sended frum dis stoopid fone
big86inthestixx is online now   Reply With Quote
Old October 29th, 2013, 07:13 AM   #3
tj84
Member
 
tj84's Avatar
 
Join Date: 12-07-07
Location: indiana
Posts: 96
iTrader: (0)
Mentioned: 0 Post(s)
Default

check the TPS it can have that same effect on it.
tj84 is offline   Reply With Quote
Old October 29th, 2013, 07:43 AM   #4
revdog
Senior Member
 
Join Date: 07-29-12
Location: chelsea mi
Posts: 206
iTrader: (2)
Mentioned: 0 Post(s)
Default

I'd adjust tv cable and make sure the lever on the trans moves freely. Also have you checked for codes?

Sent from my DROID RAZR using Tapatalk 2
revdog is offline   Reply With Quote
Old November 2nd, 2013, 09:24 PM   #5
Badmunky
Senior Member
 
Badmunky's Avatar
 
Join Date: 04-22-13
Location: Michigan (South East)
Posts: 191
iTrader: (1)
Mentioned: 0 Post(s)
Default

TV cable adjustment done. No change.
No codes.
42RE

Seams to do this more when its up to temp. But will do it at times when cold.

I had the trans serviced and there seamed to be no change.
Badmunky is offline   Reply With Quote
Old November 2nd, 2013, 09:33 PM   #6
big86inthestixx
Senior Member
 
big86inthestixx's Avatar
 
Join Date: 04-30-11
Location: howard city Mi
Posts: 2,369
iTrader: (9)
Mentioned: 3 Post(s)
Default

Quote:
Originally Posted by Badmunky View Post
TV cable adjustment done. No change.
No codes.
42RE

Seams to do this more when its up to temp. But will do it at times when cold.

I had the trans serviced and there seamed to be no change.
Id bet pretty good, that its the gov. Pressure solenoid.
This won't throw a code all of the time.
Last few ive gotten were bout 60 bux plus fluids...I adjusted the bands when I was in doing that as well.


sended frum dis stoopid fone
big86inthestixx is online now   Reply With Quote
Old November 3rd, 2013, 11:33 AM   #7
jeepitupyo
MMM Shrimp Slushy
 
jeepitupyo's Avatar
 
Join Date: 01-23-06
Location: Flint 48507
Posts: 1,979
iTrader: (25)
Mentioned: 0 Post(s)
Send a message via AIM to jeepitupyo
Default

I'd try the tps as well.

Sent from my DROID RAZR using Tapatalk 2
__________________
05 Silverado Crew Z71
00 XJ BDS Long Arms 35's
Beelby & Sons Towing
St. Pierre Inc. Machining and Welding
jeepitupyo is offline   Reply With Quote
Old November 8th, 2013, 06:52 PM   #8
Badmunky
Senior Member
 
Badmunky's Avatar
 
Join Date: 04-22-13
Location: Michigan (South East)
Posts: 191
iTrader: (1)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by big86inthestixx View Post
Id bet pretty good, that its the gov. Pressure solenoid.
This won't throw a code all of the time.
Last few ive gotten were bout 60 bux plus fluids...I adjusted the bands when I was in doing that as well.


sended frum dis stoopid fone

How do you adjust the bands?
Badmunky is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:40 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.17884 seconds with 45 queries