IOD fuse keeps blowing - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old September 20th, 2013, 06:58 AM   #1
Fidget56
Senior Member
 
Fidget56's Avatar
 
Join Date: 02-19-07
Location: Leonard Mi
Posts: 503
iTrader: (5)
Mentioned: 1 Post(s)
Default IOD fuse keeps blowing

99 cummins does anyone know where I should start looking. Or has anyone had the same issues.
Thanks for the help
Fidget56 is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old September 20th, 2013, 07:03 AM   #2
8PTBUCK
Stuntman Mike
 
8PTBUCK's Avatar
 
Join Date: 12-02-09
Location: Waterford/Gladwin, MI
Posts: 5,546
iTrader: (6)
Mentioned: 61 Post(s)
Default

Check what runs off of that fuse. Then check the wires that run to each of those things. You might have a short in one of the grounds somewhere. Get a reader and check all the wires.
8PTBUCK is offline   Reply With Quote
Old September 20th, 2013, 07:10 AM   #3
8PTBUCK
Stuntman Mike
 
8PTBUCK's Avatar
 
Join Date: 12-02-09
Location: Waterford/Gladwin, MI
Posts: 5,546
iTrader: (6)
Mentioned: 61 Post(s)
Default



LAY SOME PIPE
__________________


@shanelee78 - "stay classy!"
8PTBUCK is offline   Reply With Quote
Old September 20th, 2013, 07:13 AM   #4
JeepInABox
Jeep yard art collector.
 
JeepInABox's Avatar
 
Join Date: 10-25-07
Location: Fenton
Posts: 2,307
iTrader: (8)
Mentioned: 0 Post(s)
Default

Check the radio if it is not factory, lots of times the wires rub on sharp metal.
JeepInABox is offline   Reply With Quote
Old September 27th, 2013, 06:02 AM   #5
rammanriley
Senior Member
 
rammanriley's Avatar
 
Join Date: 09-26-11
Location: Macomb twp
Posts: 598
iTrader: (0)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by JeepInABox View Post
Check the radio if it is not factory, lots of times the wires rub on sharp metal.
X2. Have you done anything to the truck lately?

Sent from my DROID RAZR using Tapatalk 4
__________________
96 Ram 1500 ECSB 5.9l v8 4x4 On 35's
13 Dart Aero (turbo go fast)
rammanriley is offline   Reply With Quote
Old September 27th, 2013, 06:42 AM   #6
bigbchevy
missmrgreenagain
 
bigbchevy's Avatar
 
Join Date: 09-15-07
Location: fenton /hartland mi
Posts: 19,029
iTrader: (167)
Mentioned: 51 Post(s)
Default

Lots
__________________
H.o.r.e
(mr.green)So you are calling CC a liar?? Not a nice way to treat your bitch.
tube bending and gear installs pm me for info! gears installed for $150 and up per axle.
bigbchevy is online now   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:15 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.11653 seconds with 38 queries