help with my 4.0 in xj Started all over - Page 2 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old September 22nd, 2013, 04:06 PM   #21
WACKO1
2000 xj
 
WACKO1's Avatar
 
Join Date: 05-06-13
Location: waterford mi
Posts: 793
iTrader: (2)
Mentioned: 0 Post(s)
Default

First off cycle the ignition key 3 times on off on off on check engine light will start to flash count the flashes,their will be a pause and then more flashes.that will give you the code
WACKO1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old September 22nd, 2013, 04:07 PM   #22
WACKO1
2000 xj
 
WACKO1's Avatar
 
Join Date: 05-06-13
Location: waterford mi
Posts: 793
iTrader: (2)
Mentioned: 0 Post(s)
Default

The way you did it only checks the cluster self check
WACKO1 is offline   Reply With Quote
Old September 22nd, 2013, 04:47 PM   #23
hghgrad
Senior Member
 
hghgrad's Avatar
 
Join Date: 08-09-09
Location: Monroe Mi
Posts: 654
iTrader: (13)
Mentioned: 0 Post(s)
Default

The key on off trick will show the code number along with the cel flash on the 97's.
hghgrad is online now   Reply With Quote
Old September 22nd, 2013, 06:05 PM   #24
ttrailtj
looking 4 #8 Jeep
 
ttrailtj's Avatar
 
Join Date: 03-12-06
Location: Flint,mi,
Posts: 125
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via Yahoo to ttrailtj
Default

I did it, it flashed a 12, then 54 flashed 4times during the 12 a 7 times during the 54
ttrailtj is offline   Reply With Quote
Old September 22nd, 2013, 07:28 PM   #25
WACKO1
2000 xj
 
WACKO1's Avatar
 
Join Date: 05-06-13
Location: waterford mi
Posts: 793
iTrader: (2)
Mentioned: 0 Post(s)
Default

Just checked their is no 12 code, try again
WACKO1 is offline   Reply With Quote
Old September 23rd, 2013, 08:48 AM   #26
ttrailtj
looking 4 #8 Jeep
 
ttrailtj's Avatar
 
Join Date: 03-12-06
Location: Flint,mi,
Posts: 125
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via Yahoo to ttrailtj
Default

Ok, I redid it, shows codes 12, 54, 17, 45 ,22, 45, 55, anybody ?
ttrailtj is offline   Reply With Quote
Old September 23rd, 2013, 11:33 AM   #27
yyj87
Senior Member
 
yyj87's Avatar
 
Join Date: 04-10-10
Location: Traverse city(Silver Lake)
Posts: 1,681
iTrader: (1)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by ttrailtj View Post
Ok, I redid it, shows codes 12, 54, 17, 45 ,22, 45, 55, anybody ?
Google gave me the answers!
yyj87 is offline   Reply With Quote
Old September 23rd, 2013, 02:27 PM   #28
19914x4blazer
360 gamer tag mike93vr4
 
19914x4blazer's Avatar
 
Join Date: 12-19-07
Location: walled lake 48390
Posts: 1,543
iTrader: (4)
Mentioned: 0 Post(s)
Default

http://jeep-xj.info/HowtoECUcodes.htm
19914x4blazer is offline   Reply With Quote
Old September 23rd, 2013, 03:12 PM   #29
ttrailtj
looking 4 #8 Jeep
 
ttrailtj's Avatar
 
Join Date: 03-12-06
Location: Flint,mi,
Posts: 125
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via Yahoo to ttrailtj
Default

A new pickup coil installed and she fired right up! The code 54 was the culprit, thanks for everyones help
ttrailtj is offline   Reply With Quote
Old September 24th, 2013, 03:34 PM   #30
ttrailtj
looking 4 #8 Jeep
 
ttrailtj's Avatar
 
Join Date: 03-12-06
Location: Flint,mi,
Posts: 125
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via Yahoo to ttrailtj
Default

Well, went to drive it today, right back to a no fire ??????
ttrailtj is offline   Reply With Quote
Old September 25th, 2013, 12:00 PM   #31
ttrailtj
looking 4 #8 Jeep
 
ttrailtj's Avatar
 
Join Date: 03-12-06
Location: Flint,mi,
Posts: 125
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via Yahoo to ttrailtj
Default

Still showing code 54 got another pickup coil still no fire, maybe the main coil its self?
ttrailtj is offline   Reply With Quote
Old October 4th, 2013, 09:09 AM   #32
Dylan
Senior Member
 
Dylan's Avatar
 
Join Date: 08-24-06
Location: K-zoo
Posts: 1,127
iTrader: (7)
Mentioned: 0 Post(s)
Default

the pickup coil (cam sensor) and main coil (assuming you ignition coil) does totally different things. You need to go back and follow the trouble shooting steps described before. You would test the cam sensor and the ignition coil in different ways.

My guess is you have a broken wire somewhere in the harness for the cam sensor. Check the pigtail for your +5v, ground, and check the signal wire for shorts back to the ECU. if that test fine, then you need to back probe the cam sensor with 5v test light or a analog meter to check for a +5v pulse while cranking an the signal wire. If you have checked the signal wires for shorts and it test ok, you can check for the pulse at either the sensor or the ecu. If you get your +5v pulse, you should NOT be getting a code 54. If you do, its internal to the ECU.

To test the coil, you will need to check resistance in the coil plug. You can also check the pigtail that plugs into the coil. You should have a +12V with key on. The ground is shorted to by the ECU to fire the coil at the correct time. If you check your coil while cranking and get a ground pulse on one of the wires, than your ECU is getting a cam signal and something is wrong with your coil (if it didn't fire).

Good luck.
Dylan is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:59 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.27117 seconds with 56 queries