Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old September 3rd, 2013, 07:20 PM   #1
Yetti
Buy a Fiat! Save the UAW!
 
Yetti's Avatar
 
Join Date: 11-05-05
Location: 20 minutes south of Hell...
Posts: 14,382
iTrader: (10)
`97 neon speedo in op...

also the cruise isn't working but no check engine lights? any ideas
__________________
Yetti
Yetti is offline   Reply With Quote
Old September 3rd, 2013, 07:45 PM   #2
GREASYHANDS
Bloody Knuckles
 
GREASYHANDS's Avatar
 
Join Date: 03-16-09
Location: Nunica
Posts: 11,600
iTrader: (27)
Output speed sensor?
__________________
Bare Bones Offroad
RIP FS4L
2 old xj's
Meow
GREASYHANDS is offline   Reply With Quote
Old September 3rd, 2013, 07:55 PM   #3
Porscheguy
Senior Member
 
Porscheguy's Avatar
 
Join Date: 04-17-11
Location: Holland, mi
Posts: 360
iTrader: (2)
You have a 97 neon that is still on the road... Kudos to you. I put a number of head gaskets in my 98 till I sold it. Been too many years to remember....
Porscheguy is offline   Reply With Quote
Old September 3rd, 2013, 08:09 PM   #4
Yetti
Buy a Fiat! Save the UAW!
 
Yetti's Avatar
 
Join Date: 11-05-05
Location: 20 minutes south of Hell...
Posts: 14,382
iTrader: (10)
I just got this one. its only got a 127,000 on it. the radiator leaked a bit so it got parked...


I test ran the engine with radiator before doing much else. all the steel brake lines had to be replaced as well as one flex line. the interior is in good shape as is the body for the most part. its no peach but it drives good.
__________________
Yetti
Yetti is offline   Reply With Quote
Old September 10th, 2013, 08:13 AM   #5
Yetti
Buy a Fiat! Save the UAW!
 
Yetti's Avatar
 
Join Date: 11-05-05
Location: 20 minutes south of Hell...
Posts: 14,382
iTrader: (10)
Just thought l would post up that I got the speedo working. I held down the trip button with key on for about one minute. What ever I did reset the thing and it started working. Go figure?
__________________
Yetti
Yetti is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:59 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.06370 seconds with 20 queries