Stuck cam position sensor shaft? - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old November 28th, 2013, 08:15 PM   #1
gear_grinder
Senior Member
 
Join Date: 03-03-10
Location: Stanton
Posts: 167
iTrader: (1)
Mentioned: 0 Post(s)
Default Stuck cam position sensor shaft?

Hi

i've got a 97 explorer and im trying to get the cam shaft position sensor out of it (takes the place of the dizzy with the explorers DIS)

the body spins freely in the bore and the shaft spins normal with engine rotation, however it will not come out. it almost feels like the gear will not disengage the cam gear or the shaft is stuck. This CPS has only been in the engine for a few years so i really doubt its anything wear or neglect related.

I'm thinking im just going to noose it with a cable and pop it out with my engine hoist. any better ideas?
gear_grinder is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old November 28th, 2013, 09:41 PM   #2
TJ/WILLYS
Senior Member
 
Join Date: 09-29-12
Location: Marlette Michigan
Posts: 482
iTrader: (9)
Mentioned: 1 Post(s)
Default

O-ring seal stuck in the bore? Try spraying it with pb blaster, let it soak in over night.
TJ/WILLYS is offline   Reply With Quote
Old November 28th, 2013, 09:44 PM   #3
gear_grinder
Senior Member
 
Join Date: 03-03-10
Location: Stanton
Posts: 167
iTrader: (1)
Mentioned: 0 Post(s)
Default

i wouldnt think so with the housing rotating in the block bore
gear_grinder is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:31 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.08498 seconds with 31 queries