Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old August 28th, 2013, 08:42 PM   #1
trogdor the burninator
Insert Comment Here.
 
trogdor the burninator's Avatar
 
Join Date: 07-22-06
Location: Kalamazoo, MI
Posts: 6,262
iTrader: (21)
Mentioned: 0 Post(s)
Send a message via AIM to trogdor the burninator Send a message via MSN to trogdor the burninator
Default 99 5.4 f150 trans or torque converter problem?

So I already replaced the lockup solenoid. and yet I start my truck and it idles fine, revs up just dandy etc.
However; after putting it in either 1 2 drive or Reverse it bogs down, gets really lopey regardless of how far the gas pedal is depressed. will not move at all. It's pretty annoying
If someone has any ideas on what else it could be or wants to take a look at it, I will take a video and text it to them. I appreciate all the help I got here in the past and hope you guys can come through again!
__________________
Quote:
Originally Posted by mschaffer66 View Post

Don't take my guns or let them queer-o-sexuals get married, but go ahead and decide what's okay for my food. yee haw.
trogdor the burninator is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:18 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.05629 seconds with 14 queries