Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old August 12th, 2013, 08:46 PM   #21
Toivo
Feel lucky?
 
Toivo's Avatar
 
Join Date: 02-24-06
Location: Denver
Posts: 5,142
iTrader: (13)
Mentioned: 0 Post(s)
Default

Excessive water flow volume isn't good either. Swap to a normal flow pump and reevaluate. If the coolant moves thru the rad too quickly, it cannot lose heat efficiently and thus overheats.
Toivo is offline   Reply With Quote
Old August 12th, 2013, 08:47 PM   #22
chadcooper55
expert jeep disassembler
 
chadcooper55's Avatar
 
Join Date: 08-28-08
Location: kent city mi
Posts: 8,026
iTrader: (20)
Mentioned: 9 Post(s)
Default

Problem solved!!

My new stat was bad. I bought another new stat on the way home from work. I put it in and took it for a good drive and it stayed right around 190. Thank you all for your help.
__________________
I hate being bipolar, its great!

jeep turned buggy now back to jeep
http://www.greatlakes4x4.com/showthread.php?t=175584
chadcooper55 is offline   Reply With Quote
Old August 12th, 2013, 08:48 PM   #23
chadcooper55
expert jeep disassembler
 
chadcooper55's Avatar
 
Join Date: 08-28-08
Location: kent city mi
Posts: 8,026
iTrader: (20)
Mentioned: 9 Post(s)
Default

Quote:
Originally Posted by Toivo View Post
Excessive water flow volume isn't good either. Swap to a normal flow pump and reevaluate. If the coolant moves thru the rad too quickly, it cannot lose heat efficiently and thus overheats.
The one I took off was a standard flow that worked fine.
__________________
I hate being bipolar, its great!

jeep turned buggy now back to jeep
http://www.greatlakes4x4.com/showthread.php?t=175584
chadcooper55 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:10 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.06184 seconds with 16 queries