WJ transmission slips and wines - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old June 26th, 2013, 09:17 PM   #1
14muddn
Senior Member
 
Join Date: 02-10-08
Location: Wixom/MI
Posts: 1,776
iTrader: (5)
Mentioned: 0 Post(s)
Default WJ transmission slips and wines

My brother said his transmission had been slipping for a week or two and then he said it won't go past 30. I just took it for a short drive and it shifts from first to second fine under regular acceleration and at 25 slips out and the rpms jump. I could hear a pretty distinct whine I'm assuming the transmission oil pump? I haven't checked for codes but there is a check engine light I'll check when I can get ahold of a scanner (mine is old and the screen has slowly died).

This is a 99 4.7 WJ with 145k original transmission as far as I know.

Is it possible the jeep is sensing a low flowing pump and putting it into limp mode?

Someone said there are a couple sensors that are known to go out, could that be giving a similar issue?

Is it just time for a new transmission?
14muddn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old July 18th, 2013, 10:44 PM   #2
14muddn
Senior Member
 
Join Date: 02-10-08
Location: Wixom/MI
Posts: 1,776
iTrader: (5)
Mentioned: 0 Post(s)
Default

Anyone have some insight?
14muddn is offline   Reply With Quote
Old July 18th, 2013, 11:04 PM   #3
af26yrs
Senior Member
 
af26yrs's Avatar
 
Join Date: 09-04-09
Location: In the Thumb, michigan
Posts: 647
iTrader: (5)
Mentioned: 1 Post(s)
Default

I have a 42RE in my part out '04 WJ that was completely rebuilt with all new parts about 55,000 miles ago for sale. When I say completely I mean it has all new parts from clutches to sensors. $125 and you come pull it. Xfer case and drive shafts are already out so just have to take tranny out. PM me if you are interested.

As far as your problem, when was the fluid changed last? You might try dropping the pan and changing the fluid and filter.
af26yrs is offline   Reply With Quote
Old July 18th, 2013, 11:32 PM   #4
joe_jeep
welfare wheeler
 
joe_jeep's Avatar
 
Join Date: 03-03-06
Location: hazel park, mi
Posts: 5,731
iTrader: (37)
Mentioned: 2 Post(s)
Send a message via Yahoo to joe_jeep
Default

the v8 was 545rfe wasnt it?
joe_jeep is offline   Reply With Quote
Old July 18th, 2013, 11:57 PM   #5
ajmorell
Senior Member
 
ajmorell's Avatar
 
Join Date: 01-22-07
Location: Oshkosh, WI
Posts: 3,522
iTrader: (16)
Mentioned: 0 Post(s)
Send a message via AIM to ajmorell
Default

99 would be a 45rfe
ajmorell is online now   Reply With Quote
Old July 19th, 2013, 04:54 AM   #6
af26yrs
Senior Member
 
af26yrs's Avatar
 
Join Date: 09-04-09
Location: In the Thumb, michigan
Posts: 647
iTrader: (5)
Mentioned: 1 Post(s)
Default

Wasn't sure if it would fit but offered it.
af26yrs is offline   Reply With Quote
Old July 19th, 2013, 10:21 AM   #7
14muddn
Senior Member
 
Join Date: 02-10-08
Location: Wixom/MI
Posts: 1,776
iTrader: (5)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by af26yrs View Post
I have a 42RE in my part out '04 WJ that was completely rebuilt with all new parts about 55,000 miles ago for sale. When I say completely I mean it has all new parts from clutches to sensors. $125 and you come pull it. Xfer case and drive shafts are already out so just have to take tranny out. PM me if you are interested.

As far as your problem, when was the fluid changed last? You might try dropping the pan and changing the fluid and filter.
I appreciate the offer if it was a 4.0 WJ I would be all over it I saw your part out thread lol.

I'll probably drop the oil pan this weekend and if there are any signs of hard damage and pick up a scanner. I don't really want to fill the trans back up if it's going to need work done, if I remember right ATF+4 is a little spendy.
14muddn is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:01 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.11516 seconds with 43 queries