Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old June 26th, 2013, 11:55 PM   #1
Modestmar00Xj
Show me the trails!
 
Modestmar00Xj's Avatar
 
Join Date: 11-10-10
Location: Waterford, Mi
Posts: 237
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to Modestmar00Xj Send a message via Skype™ to Modestmar00Xj
Default Is My Clutch Bad?

Question jeepers!

I have a 97' TJ and I think my clutch just went out on me today! Its really hard to push in and feels like theres a lot of resistance. I checked the fluid and its full and the cable appears ok, its not broken. Do you think it could be the clutch plate? And how can you tell? Thanks.
Modestmar00Xj is offline   Reply With Quote
Old June 27th, 2013, 12:13 AM   #2
brewmenn
Grumpy old man.
 
brewmenn's Avatar
 
Join Date: 11-05-05
Location: Inkster, MI
Posts: 10,400
iTrader: (9)
Mentioned: 1 Post(s)
Default

Obviously something went bad, but probably not the clutch plate. That would not cause a hard clutch.

Start with the easy things, check the master and slave cylinder and the pedal assembly for something that would cause increased resistance.

I'm not sure where you found a cable to look at, TJ's have hydraulic clutches.
brewmenn is online now   Reply With Quote
Old June 27th, 2013, 12:22 AM   #3
Modestmar00Xj
Show me the trails!
 
Modestmar00Xj's Avatar
 
Join Date: 11-10-10
Location: Waterford, Mi
Posts: 237
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to Modestmar00Xj Send a message via Skype™ to Modestmar00Xj
Default

Ok cool ill check it out! Yeah i was looking at the linkage from the pedal to the little actuator inside the jeep. Im not sure yet but im thinking it might be the slave cylinder. Thanks man!
Modestmar00Xj is offline   Reply With Quote
Old June 27th, 2013, 07:07 AM   #4
mymizzery
Senior Member
 
mymizzery's Avatar
 
Join Date: 08-18-06
Location: Warren, Mi
Posts: 127
iTrader: (1)
Mentioned: 0 Post(s)
Default

a few years back my clutch plate exploded. One of the springs embedded in the plate broke loose and was stuck between the clutch plate and pressure plate. would not disengage. it was the night before the woodward cruise I was not happy to say the least.
mymizzery is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
Tags
clutch, shifting, transmission

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:59 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.08559 seconds with 18 queries