1992 Lincoln Town Car - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > Great Lakes 4x4 Marketplace > Vehicles for sale
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old May 10th, 2013, 09:44 AM   #1
wrath
Project Antitube
 
wrath's Avatar
 
Join Date: 11-09-05
Location: Chelsea, MI
Posts: 475
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via AIM to wrath
Default 1992 Lincoln Town Car

Runs and drives fine. Interior is dirty, windshield is temperature cracked, windows don't roll down, ABS light is on, and airbag light is throwing code for passenger airbag. I haven't tried anything else about it.

Yes, that is rust above the driver rear wheel opening.

I got it from a relative last summer who didn't drive it anymore and wanted it out of their garage so I bought it. I thought it would be a nice cruiser but it's no Cadillac. I'd like to get back to only having HP60s for Ford parts in my yard.

How about $1000 or trade me something not Ford? Except maybe some 5 on 4.5" 15" aluminum wheels, I could tolerate some Ford like that. Or 77.5-79 high pinion Dana 60s.

Click on pictures for larger versions.









wrath is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old May 12th, 2013, 07:32 AM   #2
wrath
Project Antitube
 
wrath's Avatar
 
Join Date: 11-09-05
Location: Chelsea, MI
Posts: 475
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via AIM to wrath
Default

116,500 miles (considering the lady that owned it is in her late 80s I have a difficult time believing it has more than that on it).

Passenger front window is the only one that rolls down. The other three make noise but nothing happens. No idea if they're the tape type, cable type, or scissor type window regulators.

AC does not work. The clutch engages, the pump spins a bit, then turns off.

Heat does work.

It might burn oil. When I was screwing around with it this morning I thought I saw blue smoke. I couldn't smell it but it didn't look like plain condensation. I would not be surprised if it burned oil since it has the style of head Ford engineers professed their expertise in valve guides and seals.
wrath is offline   Reply With Quote
Old May 15th, 2013, 06:10 AM   #3
wrath
Project Antitube
 
wrath's Avatar
 
Join Date: 11-09-05
Location: Chelsea, MI
Posts: 475
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via AIM to wrath
Default

Top.
wrath is offline   Reply With Quote
Old May 18th, 2013, 10:29 PM   #4
wrath
Project Antitube
 
wrath's Avatar
 
Join Date: 11-09-05
Location: Chelsea, MI
Posts: 475
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via AIM to wrath
Default

Top.
wrath is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > Great Lakes 4x4 Marketplace > Vehicles for sale

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:02 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10640 seconds with 34 queries