CHECK ENGINE LIGHT-Grand Rapids - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > General 4x4 Stuff > Meets, Greets, and Wrenching
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier All Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old April 9th, 2013, 11:34 AM   #1
joe&jeep
Senior Member
 
joe&jeep's Avatar
 
Join Date: 08-17-08
Location: Grand Rapids, Michigan
Posts: 2,188
iTrader: (3)
Mentioned: 3 Post(s)
Default CHECK ENGINE LIGHT-Grand Rapids

Who can diagnois to what exactly needs to be done, free to cheap.
Check engine light came on about a week ago and everything seems to be fine, except light doesn't go out. Been to Autozone for their free scan and got about a half a dozen things, need it pinpointed.
Thanks
joe&jeep is offline   Reply With Quote
Old April 9th, 2013, 11:39 AM   #2
srlbotanical
Because I Said So...
 
srlbotanical's Avatar
 
Join Date: 06-09-07
Location: Saranac, MI
Posts: 799
iTrader: (17)
Mentioned: 0 Post(s)
Default

sent you a pm
srlbotanical is online now   Reply With Quote
Old April 9th, 2013, 11:42 AM   #3
joe&jeep
Senior Member
 
joe&jeep's Avatar
 
Join Date: 08-17-08
Location: Grand Rapids, Michigan
Posts: 2,188
iTrader: (3)
Mentioned: 3 Post(s)
Default

recieved PM and sent PM
joe&jeep is offline   Reply With Quote
Old April 9th, 2013, 11:46 AM   #4
bdd1469
bdd
 
bdd1469's Avatar
 
Join Date: 04-12-10
Location: alto mi
Posts: 2,063
iTrader: (1)
Mentioned: 0 Post(s)
Send a message via Yahoo to bdd1469
Default

More detalis please.

What vehical? Remember any of the codes autozone gave you?
bdd1469 is offline   Reply With Quote
Old April 9th, 2013, 11:56 AM   #5
joe&jeep
Senior Member
 
joe&jeep's Avatar
 
Join Date: 08-17-08
Location: Grand Rapids, Michigan
Posts: 2,188
iTrader: (3)
Mentioned: 3 Post(s)
Default

'05 TJ 4.0
code #s I don't have, threw in trash by mistake, but they came up with a couple different ones: catalitic convertor, oxeygon sensor, vacuum leak, maf valve and something else.
joe&jeep is offline   Reply With Quote
Old April 9th, 2013, 12:47 PM   #6
JeepInABox
Jeep yard art collector.
 
JeepInABox's Avatar
 
Join Date: 10-25-07
Location: Fenton
Posts: 2,305
iTrader: (8)
Mentioned: 0 Post(s)
Default

Codes have a priority and some issues will set multiple.
Fix the one problem and they all go away
Check for vac leaks then the big 3 sensors
JeepInABox is offline   Reply With Quote
Old April 9th, 2013, 12:51 PM   #7
Dylan
Senior Member
 
Dylan's Avatar
 
Join Date: 08-24-06
Location: K-zoo
Posts: 1,121
iTrader: (7)
Mentioned: 0 Post(s)
Default

Pull power to PCM, let it sit for a bit. Then hook back up. Drive right to AZ to get codes read. See what shows up and post back. If nothing shows up, then drive around till CE light comes on and then get scanned again. Post code number (not the default description).
Dylan is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > General 4x4 Stuff > Meets, Greets, and Wrenching
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:49 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
vB Ad Management by =RedTyger=
Page generated in 1.54589 seconds with 40 queries