Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Quads, Bikes, and Sleds
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old April 5th, 2013, 09:49 PM   #1
barry1me
Just another day
 
barry1me's Avatar
 
Join Date: 06-09-06
Location: Howell, MI
Posts: 2,885
iTrader: (9)
Mentioned: 0 Post(s)
Default china 110cc ATVs....anyone have one? any issues?

my neighbor gave me his kids 2008 110cc china ATV. He got sick of being unable to make it run. It has less then 1 hour run time on it. The first issue was the carb leaking and flooding. I actually had to replace the carb as it was a piece of junk. Now im having an issue with not getting a good spark. The engine will start, and then die. Its really weird. wondering if anyone has bought one of the china atvs and been able to keep one running.
barry1me is offline   Reply With Quote
Old April 11th, 2013, 06:10 PM   #2
1_Ton_Harley
One More Toy
 
Join Date: 09-09-11
Location: Northern Michigan
Posts: 70
iTrader: (1)
Mentioned: 0 Post(s)
Default

I have two of them. They both run great. I had to put a fuel shut off on one because it was pissin gas out the carb. The other needed a new battery and they have about 100 hours each on them.
1_Ton_Harley is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Quads, Bikes, and Sleds
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 10:59 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.06233 seconds with 14 queries