Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old December 8th, 2012, 07:56 AM   #1
dowen
Sanford MI (Midland)
 
Join Date: 12-10-06
Location: Sanford MI
Posts: 1,010
iTrader: (7)
Mentioned: 0 Post(s)
Default engine cuts out

I have 99 tj with a 4.0 when I first take off in every gear it cuts out.It has new plugs wires and cap and sugestion? Thanks Denny
dowen is online now   Reply With Quote
Old December 8th, 2012, 08:40 AM   #2
rda616
Member
 
rda616's Avatar
 
Join Date: 03-08-11
Location: Allegan Michigan
Posts: 62
iTrader: (1)
Mentioned: 0 Post(s)
Default

Do you have a check engine light on? I'm leaning toward the iac being dirty and needing replaced. Try taking it out and cleaning it.
rda616 is offline   Reply With Quote
Old December 8th, 2012, 09:30 AM   #3
yyj87
Senior Member
 
yyj87's Avatar
 
Join Date: 04-10-10
Location: Traverse city(Silver Lake)
Posts: 1,671
iTrader: (1)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by rda616 View Post
Do you have a check engine light on? I'm leaning toward the iac being dirty and needing replaced. Try taking it out and cleaning it.

x2 I have had 2 iacs go bad and both left me with issues just off idle.
yyj87 is offline   Reply With Quote
Old December 8th, 2012, 03:57 PM   #4
dowen
Sanford MI (Midland)
 
Join Date: 12-10-06
Location: Sanford MI
Posts: 1,010
iTrader: (7)
Mentioned: 0 Post(s)
Default

No light on!!!!! not being dumb or anything but whats a iac ?
dowen is online now   Reply With Quote
Old December 8th, 2012, 04:10 PM   #5
AceMon
Could've had a v8
 
AceMon's Avatar
 
Join Date: 04-14-09
Location: Elgin, IL
Posts: 517
iTrader: (2)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by dowen View Post
No light on!!!!! not being dumb or anything but whats a iac ?
IAC = idle air control valve
AceMon is offline   Reply With Quote
Old December 8th, 2012, 06:08 PM   #6
dowen
Sanford MI (Midland)
 
Join Date: 12-10-06
Location: Sanford MI
Posts: 1,010
iTrader: (7)
Mentioned: 0 Post(s)
Default

Thanks I will try that!!
dowen is online now   Reply With Quote
Old December 11th, 2012, 07:41 AM   #7
dowen
Sanford MI (Midland)
 
Join Date: 12-10-06
Location: Sanford MI
Posts: 1,010
iTrader: (7)
Mentioned: 0 Post(s)
Default

Cleaned the iac, didnt look dirty at all!!! have drove it yet
dowen is online now   Reply With Quote
Old December 12th, 2012, 11:21 AM   #8
Miller 99
Member
 
Miller 99's Avatar
 
Join Date: 11-26-12
Location: Lake Geneva WI
Posts: 35
iTrader: (0)
Mentioned: 0 Post(s)
Default

I had this once my cps wire had a bare spot in it and was swinging and shorting out on the intake manifold or the header I forget witch one. Ether way when I found it I was like, NO Fucking Way!!! LOL Might be the only time it happens but it's worth it to check.
Miller 99 is offline   Reply With Quote
Old December 12th, 2012, 05:36 PM   #9
dowen
Sanford MI (Midland)
 
Join Date: 12-10-06
Location: Sanford MI
Posts: 1,010
iTrader: (7)
Mentioned: 0 Post(s)
Default

thanks i will look around
dowen is online now   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:49 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.13712 seconds with 30 queries